80 karma · joined May 22, 2015
I never trust them again with my data.
Codex was generating code, that began with ... Copyright [real name] ...
My fear were not patents, because the code is too simple, but similarity to existing code from this company. I did not know if this could lead to problems if the architecture or the code itself is too similar.
>> I'm the co-founder of an interview prep mentorship platform [...] my company's services so there is a small amount of overlap on the most experienced end of Codesmith and the least experienced end of Formation. <<
https://www.reddit.com/r/codingbootcamp/comments/18cpq98/ana...
(alternatives for other OS: https://alternativeto.net/software/mailsteward/)
Then I put the database on multiple backup locations regularly.
Another thing, some people do not already know: If you don't need a throwaway-adress for some services, and you just want to make your mailbox more structured, you can use '+' before the '@' to add another word to your email adress.
Like: your.name+randomName@gmail.com
The +randomName will be ignored and the emails are received at your.name@gmail.com. But most Servers (I use) will put a '[randomName]' before the subject of the received email. Which can be quite handy for handling your emails. Even more, if the company uses multiple different adresses to send you emails.
What could go wrong *lol
But wait, how can you connect to Port 22 then? I use Tailscale as a VPN for this. I installed Tailscale on my local computer and my servers, so I can use the VPN to connect to this port. The less open ports, the better.
What else... Use fail2ban or CrowdSec for banning IPs that probe your server. Don't use passwords for authentication. Don't use root, use another user. ... stuff you maybe already heard of or know. Here is a link to get started: https://blog.codelitt.com/my-first-10-minutes-on-a-server-pr...
If you knew this already, sorry, I wasn't sure where to start.
Maybe use a Hoster that provides 'Snapshots'. So you can safely play around and if something happens, just revert to your last snapshot, so you don't loose your previous work.
If you spin up a server, maybe use cloud config. You can use it to 'bootstrap' your server and let it install your main tools while it gets provisioned.
It looks something like this (HackerNews removes my line breaks...): ####
#cloud-config for installing fail2ban
package_upgrade: true
packages:
- fail2ban
runcmd: - [ systemctl, enable, fail2ban ]
- [ systemctl, start, fail2ban ]
####If you start and mess up something, it's handy if you have a cloud init to start a new server and don't have to install the basic stuff again ;-)
1.) Because the first thing I thought was 'what's their business model?'.
2.) Because why not calling it an unlimited Trial with 10 items, to make it clear it's not free.
Don't get me wrong - I like to pay for software, because I want to honour the work of others.