HNHacker News
TopNewBestAskShowJobs

CaliforniaKarl

10,031 karma · joined March 4, 2016

Hello! I work at Stanford University, at the Stanford Research Computing Center, as an HPC sysadmin.

I have a blog: https://karl.kornel.us/

My HN handle is also my Twitter handle.

My work email is a!k!kornel@stanford,edu (with ! removed and , corrected).

submissionscomments
CaliforniaKarl··on More than you wanted to know about how Game Boy cartridges work
See also the Ultimate Game Boy Talk from 33c3: https://www.youtube.com/watch?v=HyzD8pNlpwI
CaliforniaKarl··on Linux and Secure Boot certificate expiration
Trusted timestamp services. https://en.wikipedia.org/wiki/Trusted_timestamping

Microsoft's Authenticode has been doing this for a long time, allowing a signature to be considered as valid long after the signing certificate expired.

https://learn.microsoft.com/en-us/windows/win32/seccrypto/ti...

CaliforniaKarl··on Apple and Masimo Faced Off in US Appeals Court This Week
https://archive.md/MhQFb
CaliforniaKarl··on Postgres LISTEN/NOTIFY does not scale
I did not use ChatGPT—nor any AI—in writing the post. I'm curious, would you mind emailing—or replying—with what made you think that it was written by AI? Or why you do not believe my statement?
CaliforniaKarl··on Postgres LISTEN/NOTIFY does not scale
I appreciate this post for two reasons:

* It gives an indication of how much you need to grow before this Postgres functionality starts being a blocker.

* Folks encountering this issue—and its confusing log line—in the future will be able to find this post and quickly understand the issue.

CaliforniaKarl··on CU Randomness Beacon
Ah, another randomness beacon! Although I wish it used the same API as NIST's beacon, either the v1 or v2 API.
CaliforniaKarl··on Debian on Apple M1/M2: status and call for testers
That link points to a "multiple messages with this ID" page. Suggest pointing to https://lists.debian.org/debian-devel/2025/06/msg00241.html
CaliforniaKarl··on Bolt CEO ends unlimited personal time off policy
The article's full title is "San Francisco tech CEO ends unlimited personal time off policy, calls it ‘totally broken’"; I've edited it per HN Guidelines.
CaliforniaKarl··on The Bleach Community Is Ready for RFK Jr. To Make Their Dreams Come True
And even in a professional setting, there can be accidents.

https://pubmed.ncbi.nlm.nih.gov/24090808/

CaliforniaKarl··on CertMate – SSL Certificate Management System
RFC2136 would let you do that, though setting it up is “an exercise left up to the reader”. My suggestion would be to get RFC2136 working with certbot first.
CaliforniaKarl··on Getting ready to issue IP address certificates
Assuming your device gets an IP via DHCP, there is a solution that does not involve hard-coding IPs into software.

DHCP option 42 (defined in RFC 2132) can be used to specify multiple NTP server IPv4 addresses.

(There’s also DHCP option 4, but that’s used to specify the IP for the older RFC 868 time protocol.)

DHCPv6 has option 31 for SNTP (via deprecated RFC 4075), and option 56 for NTP (via RFC 5908).

So, that would probably be the best option: Get an NTP address from DHCP or DHCPv6, use that to set your clock, and then do whatever you need!

(Yes, it does require that you trust your DHCP source, and its NTP reference.)

CaliforniaKarl··on Harvard hired researcher to uncover slavery ties, fires him for finding slaves
Where was it that you read about this?
CaliforniaKarl··on U.S. Chemical Safety Board could be eliminated
When something happens, the real cause of the problem is often due to a combination of the entity (the company/person/whatever that had the "something" happen), as well as external factors. Those external factors can include rules/guidance—or the lack of rules/guidance—from multiple agencies.

If a regulatory agency is also doing investigations, they may choose to focus less on their own 'failings' (that is, their agency's rules/guidance or lack of rules/guidance), and focus more on others' failings. Or, they may choose to focus less on other agencies' failings for political reasons.

Having a third party, with no regulatory ability, helps to reduce the appearance of bias, and increase trust in the industry that the third party investigates.

CaliforniaKarl··on Judo Bank tricked me into giving away my business ($10M value) also my home
Some context, not attempting to take away from the story: The people and companies in this post are all in Australia.

One other thing that interests me, the English Wikipedia page on Judo Bank (https://en.wikipedia.org/wiki/Judo_Bank) has an interesting note at the top: "This article may have been created or edited in return for undisclosed payments, a violation of Wikipedia's terms of use."

CaliforniaKarl··on EU Eyes Ditching Microsoft Azure for France's OVHcloud
It will start to build a positive reputation for the client, prompting the provider to take the greater risk.
CaliforniaKarl··on A Rural Public Transit Odyssey
For folks in the Bay Area, a challenge: Do a loop around the bay by non-commuter bus only. That means you can use skip-stop routes like Muni's 9R, but you cannot use routes like AC Transit's OX line. You also cannot use the Dumbarton Express, since it cuts off the South Bay.

It's an interesting experience, and it (or some portion of it) is one that many folks do every workday.

CaliforniaKarl··on The magic of through running
> It seems like it was only recently that bart reached an airport.

How recently is recently?

BART’s SFO station opened June 2003, and the OAK station opened November 2014.

CaliforniaKarl··on Convert photos to Atkinson dithering
There's no guarantee that the site's creator is (or becomes) aware of this thread, so when possibly it's nice to give them a heads-up! I have just done so: https://github.com/gazs/canvas-atkinson-dither/issues/2
CaliforniaKarl··on Understanding the PURL Specification (Package URL)
Or PURLs in general, the concept for which was developed in 1995, per https://en.m.wikipedia.org/wiki/Persistent_uniform_resource_...
CaliforniaKarl··on Getting a Cease and Desist from Waffle House
As great as Waffle House is, this is a good reminder that they are a corporation, and so must not be trusted.
CaliforniaKarl··on Ask HN: As a customer, how to stop non-criminal misconduct with small damages?
Also…

* Regarding the sealed food, I have reported faulty packaged-food items to the manufacturer two or three times, and in each instance was provided with a coupon for a free replacement.

* Regarding the store not having an item that they thought they did, you may find that there was no agreement in place requiring them to make it right, especially if no payment was exchanged, or if said payment was refunded. You may be limited to the “court of public opinion” that is Google Maps reviews etc..

But for the other two items, small-claims court, optionally preceded by a strongly-worded letter from a lawyer: You may find that an hour of lawyer time is worth it, to write such a letter and to generally act as a ‘sounding board’ for your issue.

CaliforniaKarl··on Ask HN: As a customer, how to stop non-criminal misconduct with small damages?
Assuming this is the US, small claims court.
CaliforniaKarl··on Valve takes another step toward making SteamOS a true Windows competitor
You may be interested in purchasing a Steam Deck, or similar product. I am in a similar situation, where home machine is a Mac Mini. I wanted to play various games, but did not want to purchase (and maintain) a Windows machine. A Steam Deck—plus USB-C dock, connected to monitor and speakers—has been a good substitute for me.
CaliforniaKarl··on Ending TLS Client Authentication Certificate Support in 2026
> This change is prompted by changes to Google Chrome’s root program requirements, which impose a June 2026 deadline to split TLS Client and Server Authentication into separate PKIs.
CaliforniaKarl··on GM Is Pushing Hard to Tank California's EV Mandate
If the EV mandate is killed, I could see the California state government making that case before the courts.
CaliforniaKarl··on Microsoft support for "Faster CPython" project cancelled
https://www.linkedin.com/posts/mdboom_its-been-a-tough-coupl...
CaliforniaKarl··on Fired whistleblower: Computacenter IT guy let gf into Deutsche Bank server rooms
The too-long title is "Computacenter IT guy let girlfriend into Deutsche Bank server rooms, says fired whistleblower". The posts's title is my attempt at shortening it to fit within HN's limits.
CaliforniaKarl··on When flat rate movers won't answer your calls
Are you going to raise the issue with your MP?
CaliforniaKarl··on US Postal Service banner alerts are simply someone (un)commenting the HTML
I like this. Make it easy to put out important information quickly.
CaliforniaKarl··on [dead]
This is not just used for folks in the medical fields, it's something that lots of businesses use! In the US, it's often called a "DBA (Doing Business As) Name" or a "Fictitious Name".

You can read about California Fictitious Names here: https://calosba.ca.gov/for-small-businesses-and-non-profits/...

← PreviousPage 4 of 34Next →