HNHacker News
TopNewBestAskShowJobs

tambre

965 karma · joined November 30, 2017

raul@tambre.ee
submissionscomments
tambre··on NASA said to be investigating first allegation of a crime in space
> space station citizens

What do you mean? People are governed by the laws of their respective countries per signed treaties, as explained in the article.

tambre··on Show HN: Procrastinating? Take a 5min break without leaving your computer
Unfortunately the pictures seem to be intentionally cropped to be low-quality with apparent JPEG artifacts. Originals look great. Granted my screen is 2560x1440, so it's more apparent, but still.
tambre··on Google search takes 7 seconds on certain queries
They seem to use load balancers, so it indeed should be that easy, unless they haven't migrated to EC2 VPC.

I doubt they have any IP-dependent code, since their main selling point is not tracking anything.

tambre··on Google search takes 7 seconds on certain queries
Not the parent, but a stupid reason why I can't use DDG is that it doesn't support IPv6. It's extremely unhelpful when you're doing some IPv6-only testing and then can't search for answers.

As far as I can tell, 6 years ago the reason was that AWS didn't support IPv6[0]. It has for 2.5 years by now though.

[0] https://web.archive.org/web/20180909174057/https://duck.co/f...

tambre··on Why do developers at Google consider Agile development to be nonsense? (2016)
Same in the company I work at, but only for IT employees. It's fine as long you have over 80% of the monthly hours in you contract tracked. Definitely not used for micromanagement. I myself find it useful for seeing inefficiencies in what I do and ensuring I actually go home.

It's handy for charging clients for development work specific to them.

tambre··on Implement mechanism to wait on any of several futexes
> Wine emulator

Wine stands for "Wine Is Not an Emulator".

tambre··on What a bad day at work taught me about building Stack Overflow’s community
I don't think it's clear from the parent's post that editor was a moderator.
tambre··on What a bad day at work taught me about building Stack Overflow’s community
One should ask TeX related questions on the TeX SE[0] instead of SO.

[0]: https://tex.stackexchange.com/

tambre··on Howto: Block Amazon and any site using Amazon Web Services
This tutorial's of limited use to 30% of users, who have IPv6.
tambre··on Ask HN: Has anyone got a job by contributing to open source projects?
Google Chrome is not open source. Chromium which contains the guts is.

You should include some minimal contact information, because as of now I can't find any way to contact you. Been a Chromium contributor for a little while, so I might've been able to help a bit.

tambre··on Facebook is embedding tracking data inside the photos you download
Those who agreed to the terms of service and uploaded their pictures.

This is akin to asking who gives Facebook the permission to badly compress pictures? The answer's same.

tambre··on iMessage: Malformed Message Bricks iPhone
> [...] at the CCC congress

Your "congress" is redundant because CCC=Chaos Communication Congress.

tambre··on Route Leak Impacting Cloudflare
HN hasn't been on Cloudflare for almost a year now. Straight to their origin server it seems.
tambre··on Serveo: Expose Local Servers to the Internet
Fortunately we're being uncrippled again by the continued deployment of IPv6 [0].

[0]: https://www.google.com/intl/en/ipv6/statistics.html

tambre··on Wine Developers Concerned with Ubuntu Dropping 32-Bit Support
> [...] but especially emulation which is already complex and going to push hardware.

Wine stands for "Wine Is Not an Emulator". It's a compatibility layer.

tambre··on Ray Tracing with Metal [video]
And Linux.
tambre··on Google – My Activity
Librem 5? [0]

[0]: https://puri.sm/products/librem-5/

tambre··on Material Design Guidelines for Dark Mode
supported-color-schemes is a HTML tag indicating if the website supports dark mode (useful for auto-darkening support) and the media query is for actually implementing it.
tambre··on Show HN: WildDuck – Self-hosted modern email server
Furthermore, DigitalOcean silently drops all SMTP traffic on IPv6, which can be really confusing since you'll simply timeout and it isn't mentioned in the documentation. They do that because they implemented IPv6 against all standard industry practices (which were helpfully gathered in a RFC) and within hours of launching IPv6 the few /64s from which they were allocating customers /124s to landed on blacklists.

It's been 5 years since and they still have no plans to do IPv6 properly and allocate /64s [0].

This is the main reason I switched to Linode, who will happily allocate you a IPv6 range (/116, /64, /56) that can be rerouted between VPSes with a simple ticket (takes <1 hour).

[0]: https://ideas.digitalocean.com/ideas/DO-I-1366

tambre··on Tell HN: Archive.is inaccessible via Cloudflare DNS (1.1.1.1)
I think your accusations are factually incorrect. EDNS was created back in 1999 (RFC2671[0]) waaaaay before Google's 8.8.8.8 in 2009.

And Cloudflare is EDNS-compliant. They simply choose not to enable the optional EDNS extension released in 2016 for sending the client subnet for privacy reasons.

Here's what RFC7871 – Client Subnet in DNS Queries[1] says about itself (emphasis mine):

This document defines an EDNS0 [RFC6891] option to convey network information that is relevant to the DNS message. It will carry sufficient network information about the originator for the Authoritative Nameserver to tailor responses. It will also provide for the Authoritative Nameserver to indicate the scope of network addresses for which the tailored answer is intended. This EDNS0 option is intended for those Recursive Resolvers and Authoritative Nameservers that would benefit from the extension and not for general purpose deployment. This is completely optional and can safely be ignored by servers that choose not to implement or enable it.

As far as I know, the standard practice, before this optional EDNS extension was to do GeoDNS based on the resolver's IP. This works just fine, including in the case of Cloudflare, since they've got 150+ POPs with each resolving on their own. That's higher density than most CDNs.

[0]: https://tools.ietf.org/html/rfc2671

[1]: https://tools.ietf.org/html/rfc7871

tambre··on Tell HN: Archive.is inaccessible via Cloudflare DNS (1.1.1.1)
The fallback should be to do GeoDNS based on the resolver's IP. In case of Cloudflare that's certainly good enough, since they've got 150+ POPs.
tambre··on Tell HN: Archive.is inaccessible via Cloudflare DNS (1.1.1.1)
Cloudflare does support EDNS. They just don't forward the client's subnet due to being privacy-oriented, doing which is optional and perfectly valid.
tambre··on It’s Hard to Learn French in Middle Age
What website/application would you recommend for spaced repetition of vocabulary?

I've found the changing Windows logon screens quite nice, since every other day or so there's a new beautiful picture along with a few bubbles of text in German, enabling me to learn a few new words (though I'll probably forget most of them).

tambre··on Fastly S-1
They acquired Firebase. On Firebase Hosting for apex domains one needs to add Fastly's Anycast IPs. Switching CDNs would be a nightmare.

One related gripe I have with Firebase Hosting is that it refuses to renew certificates if you also add IPv6 addresses.

tambre··on In Estonian parliamentary election, 44% of the votes were cast online
Do you mean the public database of everyone's public keys? Tampering with that would get noticed really fast and anything like that would greatly erode the trust in the system and wreak havoc on the economy since most stuff is signed digitally.
tambre··on C++ Modules Might Be Dead-On-Arrival
What about using `if constexpr`? Sure, there currently are no equivalent constant variables to use, but adding those should be very easy.
tambre··on Is there hope for IPv6?
> What you should be interested in is the velocity of IPv6 adoption growth among ISPs and countries where adoption stopped all together, to know what to expect from actual adoption in coming years. (it's basically a failure btw)

I don't understand. Are you telling me to look at how IPv6 adoption is among countries, where IPv6 usage growth has stopped? Are there any such countries? Furthermore, I'm not sure what you mean by "actual adoption". Every statistic I look at, as referenced in my previous comment, I see IPv6 usage continuing to grow. And you're calling that "propaganda"?

tambre··on Is there hope for IPv6?
> it's no wonder the transition to IPv6 has stopped

Where are you getting that from? Looking at public IPv6 statistics from big companies shows that it's going up. Google's shows a 4.5% increase in IPv6 of total traffic during the past year[0]. Facebook's shows a 6% increase and at 55% for the US [1]. Meanwhile Mexico went from 5% IPv6 to 25% this year [2].

[0]: https://www.google.com/intl/en/ipv6/statistics.html [1]: https://www.facebook.com/ipv6/?tab=ipv6 [2]: https://www.vyncke.org/ipv6status/project.php?metric=p&timef...

tambre··on Is there hope for IPv6?
Verizon started customer IPv6 rollout in select areas this autumn.[0]

[0]: https://www.dslreports.com/forum/r32136440-Networking-IPv6-w...

tambre··on Half-life
> Access denied

You'll have to adjust the permissions on that document.

← PreviousPage 7 of 10Next →