199 karma · joined December 7, 2009
Sometimes the upstream blocklist provider will be easy to contact directly as well. Sometimes not so much.
$ dig +short ns1.digitalocean.com aaaa
2400:cb00:2049:1::adf5:3a33
$ dig +short ns1.linode.com aaaa
2400:cb00:2049:1::a29f:1a631.1.1.2 and 1.1.1.3 both return the SVCB records for 1.1.1.1. (I don't know if clients would ignore them, or actually switch to 1.1.1.1.)
Non-SVCB-type queries for _dns.resolver.arpa return NXDOMAIN instead of NOERROR. (This probably doesn't have significant impact, but might break it for some clients, e.g. if they can be tricked into making queries for _dns.resolver.arpa, or if a downstream resolver makes DS queries.)
https://console.aws.amazon.com/ec2/v2/home?region=us-east-1#...:
(Edit: I hope I didn't sound sarcastic. I don't open random console pages and scroll all the way down to check for new features. Some people will have noticed, some won't.)
(There's a corner case related to DNSSEC that can make it go higher, but that's being worked on, and isn't relevant here.)
In this situation, the nameservers were just down. I haven't done exhaustive research, but the resolvers I'm aware of cache that kind of thing for no more than 15 minutes.
The instagram.com zone itself uses a third-party DNS service and didn't go down. (But e.g. www.instagram.com is a CNAME to a zone on FB DNS.)
That's not correct. https://rpki.cloudflare.com/?view=bgp&asn=13335 itself says Cloudflare still doesn't sign 12% of them.
(And a /48 from APNIC???)
(Edit: And a /36, /40 and /48 from APNIC?)
I'm not sure nothing else is wrong, but the IPv6 issue is likely why 1.1.1.1 is having trouble resolving it.
Picking a random domain hosted on those nameservers, mdfs.net, it looks like, of the 4 IPs, 2 are down and 1 of the remaining ones doesn't support TCP.
http://dnsviz.net/d/mdfs.net/W48OcQ/dnssec/ https://ednscomp.isc.org/ednscomp/4040283963
1.1.1.1 is less tolerant than some resolvers of that level of breakage.
https://community.cloudflare.com/t/ipv6-timeouts-appear-to-b...
The server-side part of DNS validation takes about a second. The delay is all about clients waiting for their authoritative DNS servers to update. If you use a fast DNS provider, there's no reason to wait longer than necessary.
> If any certs were issued for hijacked domains (which as far as I've ready was only one, not using LetsEncrypt), it's a pretty glaring failure on the issuer, assuming they used "DNS Validation"
It wouldn't be a compliance failure, though. CAs are not required to be invulnerable to BGP hijacking attacks.
Certbot can use different plugins for validating the name and for installing the certificate.
You can configure HTTP-01 to work and use "certbot -a webroot -i nginx -w /path/to/whatever -d example.com -d www.example.com".
https://community.letsencrypt.org/t/solution-client-with-the...