HNHacker News
TopNewBestAskShowJobs

ksjskskskkk

164 karma · joined November 28, 2023

submissionscomments
ksjskskskkk··on Ask HN: What apps have you created for your own use?
you can use matrix and integrate all those (whatsbook, telegram, irc, etc) into a single client. most clients have os integration and custom notification settings
ksjskskskkk··on Apple now requires a judge's consent to hand over push notification data
not exactly. on ios it's 100% their servers with wide open data.

elsewhere if you use firefox their webnotification push servers use a e2ee schema.

also on Android apps have the option to not use google's server and pull (e.g. ntfy)

... aren't you glad you bought an iphone thanks to all that "we respect your privacy" marketing? /s

ksjskskskkk··on Apple now requires a judge's consent to hand over push notification data
it's only for some American citizens.

i.e. currently in America. not in some secret list. etc. the usual.

ksjskskskkk··on Hardening cellular basebands in Android
the other commenter found the right source. but also, remember all DoS wich corrupt memory ARE complete compromise. the original researcher just gave up before they found how.

baffles me that people here fall for this simplistic excuse of "it just corrupt memory"

or things like "the modem is isolated from the phone". sigh. how do you think they configure your phone via a text message? the protocol is safe but the payload is crazy powerful and trivial to abuse.

no phone expects the modem to be an adversary. and every modem firmware is wide open. everyone just pretend it's not and hope the NDAs will work keeping the modem security holes from falling into the wrong hands. heh.

ksjskskskkk··on Hardening cellular basebands in Android
yeah. and the fix came on the system wide update. which does not touch the modem firmware. so they fixed the root from modem to phone end point. not the modem problem.

also, it was the first update to be delayed over 40days from the usual calendar. because the issue was seen in the wild a week before the release date so they scrambled to include a patch and delayed everything

ksjskskskkk··on E-books are becoming tools of corporate surveillance
its one example. then she list 4 others. your company probably gives you safari books and lynda... ALL of those record every single action for DRM purposes. the side effect is that now you reading list, how long, what time you read which line etc is all collected and readily available to anyone as we know what happens to all data (from marketers to gov to law enforcement etc)
ksjskskskkk··on Hardening cellular basebands in Android
it probably is, but you won't get the usual academic work for free as you get with more common platforms.
ksjskskskkk··on Hardening cellular basebands in Android
> , it can lead to complete device compromise.

lile they had on the flagship pixels just 8mo ago.

the csv google downgraded the severity because there was a work around of "disabling 5/4g" in a market that offset 3g. heh.

ksjskskskkk··on Low Latency, Low Loss, and Scalable Throughput (L4S) Internet Service: RFC 9330
a rfc which simply sells two others rfc... sigh

> Center TCP (DCTCP) [RFC8257] and a Dual-Queue Coupled AQM [RFC9332]

this only exists to ask that cable modems (and maybe mobile phones?) use that too

ksjskskskkk··on Low Latency, Low Loss, and Scalable Throughput (L4S) Internet Service: RFC 9330
you'd never guess: a new heater bit
ksjskskskkk··on Apple and some Linux distros are open to Bluetooth attack
both stacks were coded by broadcom(?) in the 90s, open sourced as apache license, abandoned, and recently maintained by a single RH engineer assigned 50% to it under the freedesktop org. who most change stuff so it work with wireplumber audio stuff. it got a 1.0 release recently because they fixed the new api, sill same codebase for the "actual dealing with bt radios"

i say both because most apple code is lifted from it.

ksjskskskkk··on A few of the things we're excited about in crypto (2024)
this is so funny. besides the clickbait advanced year, item 1 is "decentralization won", item 2 is "decentralization had difficult UX, passkey fixed that with centralization" lol.
ksjskskskkk··on 5Ghoul: Unleashing Chaos on 5G Edge Devices
you are way out of date on how bad things are.

just moving sim card to another phone will completely block you any access until you "reactivate" in the majority of telcos around the world.

ksjskskskkk··on Spoofing DNS records by abusing DHCP DNS dynamic updates
if you know all you can do with a default AD install, you won't even bother with dns poisoning.
ksjskskskkk··on Choose your own IP
are those discarded documented somewhere so we don't walk in circles?
ksjskskskkk··on Bitcoin tops $44,000 since April 2022 as ETF optimism grows
would you fall, like you are now, if they weren't?
ksjskskskkk··on Bitcoin tops $44,000 since April 2022 as ETF optimism grows
they are pushing really hard.

tiktok is full of "leaked" photos of some hsbc employee (just a guy sitting in a subway) looking at a PowerPoint about their btc etf.

it's such a low effort fake it's laughable, but enough for the remaining bag holders to fall.

ksjskskskkk··on Bitcoin tops $44,000 since April 2022 as ETF optimism grows
buy the rumor, sell on the news.

repeat. and in btc case you even repeat the rumor. lol

ksjskskskkk··on Microsoft Outlook Blocking All Email from Tutanota.com Domain as Spam
sounds like you paid to have their spam filter look the other way for your ips
ksjskskskkk··on Permanent and verifiable mirror of the hunter2 IRC transcript
like how static.space doesn't load with js
ksjskskskkk··on Movi: A fast and cache-efficient full-text pangenome index
so just a more losy Move? skip one third of the index which have low hits and reindex when location for those are needed?
ksjskskskkk··on Why does everyone install crates globally?
why not add cargo-awesometestrunner to dev dependencies?
ksjskskskkk··on Thunderbird for Android / K-9 Mail: October 2023 Progress Report
me too! it was practically a non profit acquiring a non profit. wild! 2022 was a crazy year.
ksjskskskkk··on The 1988 shooting down of Flight 655 as a user interface disaster
I'm more worried when spacex "pivots" to iron dome like products.

you will get a barrage of missiles raining down from space on top of some kindergartens because the autofire ai correlated a bunch of Toyota suvs moving to the same point with terrorists

ksjskskskkk··on What happens when your AI girlfriend dies?
I'm still morning Tata.
← PreviousPage 5 of 5