Of course, RAR usage nowadays is probably a bit more limited to things like usenet downloads, so the people caring enough to install an alternative decompressor is narrowing.
376 karma · joined September 23, 2014
Of course, RAR usage nowadays is probably a bit more limited to things like usenet downloads, so the people caring enough to install an alternative decompressor is narrowing.
That's coming from my kubernetes background though, and handling secrets this way is not something that people are always accustomed to.
Something something seventh incarnation. This is hardly the first time they've changed architectures. I'm actually a little impressed they actually held on this long.
Intel emulation effectively sucks compared to native apps in every way.
This is where we are.
https://learn.microsoft.com/en-us/windows/client-management/...
And that "simple Windows API" call is pretty much absolute, since it's across the stack.
After Acurite shennanigans finally broke my setup, I wrote an MQTT ingest module for weewx, because I couldn't find one that worked.
With some fairly boilerplate ESP32 code, it's trivial to hook up whatever sensor you want.
I tried to keep it generic as possible. Cheers.
then I couldn't
1. Writing about Apple simply isn't interesting anymore. Nor has it been for close to a decade. They lost me around the butterfly keyboard fiasco.
I know this isn't the full body of your work, but it's plenty of it. As a professional in the tech space for over 25 years, I went from being a devout Apple follower (installed the OSX beta on my Tibook back in the day), to basically not caring. They've gone from being innovative and evolving, and the best mix of Unix+GUI, to just being a system I'm forced to use for work. I'd rather use a Thinkpad/XPS/etc with Linux for anything else.
2. Your writing has gotten dramatically more... cynical over the years? Maybe it's just a side effect of growing older, as I know I have too. But it's also why I stopped blogging on my blog, which was popular enough in enough circles.
Like I said, this is just my perspective, so you can call me full of crap or whatever.
On a scale from 0-100, you have very cold and very hot.
Or you’ve got from 0-45. Where 0 is “meh” cold and 45 is incredibly warm.
So you’ve got a nice little 0-100 scale that all humans are going to experience just living that goes from very cold to very hot.
Or you’ve got a useless 0-100 scale that the bottom just means freezing, and ignores every pain point of being really cold below that, and anything really greater than 50C only has practical applications in cooking.
Unfortunately the only thing alternative clients for are good for now is getting banned.
Unless you are a narcissist (probable billionare) who feels the need to go back and explain every detail about the wizarding world you created a few decades later and reveal what kind of piece of crap you are.
You mean an RFC1918 for etherboot? I have a "few" of these devices and this simply doesn't make any sense in any context.
The 2030 flag day for ipv4 is just a dream.
I use longhorn on ext4 and never have issues at all
> I have grievances against OpenBSD file system. Every time OpenBSD crash, and it happens very often for me when using it as a desktop, it ends with file corrupted or lost files. This is just not something I can accept.
Doesn’t openbsd use a fancy-ish ZFS type file system?
I have the same grievance with XFS on Linux though. For as much as people say how awesome it is, the few nodes I have running XFS are the least reliable pieces of garbage on a hard power off and a pain to get back up (if I don’t just nuke it anyway)
And both labels and burned in
I love it when people just make up numbers with zero backing.
You know MACs only HAVE to be unique on the same L2 segment right?
So with every device that has MAC addresses (including every Bluetooth or WiFi device), ESP32s, home assistant type stuff, all which have usually 2 or more MACs, do you really think it makes sense for a manufacturer to use a MAC once and never again?
No. It’s called manufacturing and shipping logistics. It’s far easier than what you suggest.
As far as your made up stat here, I should play the lottery because it’s happened at least two times over the course of a 30 year career.
In 2006, I was part of a team building up a data center, and each server needed 4 NICs for iscsi speed and redundancy.
Two cases out of 10, something like 40 or 50 NICs were identical to each other. The only reason we noticed is because this job required meticulous asset tracking. My guess is because we had ordered so many NICs, the supplier had needed to hunt a little to fill the order.
The second time was when I ordered a lot of ProBooks off eBay for hackintoshing back around 2012. Again, at least two of them had the same physical MAC burned into the motherboard. And I’m guessing it’s because about half of them came from Florida and the other half came from Vancouver.
I’m just telling you, MAC addresses aren’t as unique as you are trying to suggest because they don’t need to be.
And
> elite hacking crew
It was your comment. Not to mention the blog post to which I originally responded to said “ you might not want to put your servers on low numbered IPs “
Step 1, know the difference between UDP and TCP and even a few of the implications
Yep. Party on
I responded to this elsewhere.
> I just checked the first VoIP server I ever deployed with a non-standard SIP port. It's been up for a decade and provides public facing services so its accessible to the global internet minus whatever systems have found their way in to our denylist over the years.
And that is what is called “UDP”. Also the “spray and pray” of the networking world. Meaning, you literally don’t get a response.
Fundamental difference.
> The thing about non-standard ports is that unless your service identifies itself with a banner or similar upon connection the attacker has to open with a valid request to receive a response.
Which is exactly what ssh does and the point of why comparing the two and obscuring the port/IP makes no difference.
The point is it takes a script kiddy about 5 minutes to scan the whole 4 billion IPs for your port 22 server.
It takes about 90 seconds for the fact that you opened up a random high numbered port that is an SSH service to show up on the list of people that are probably exponentially more intelligent than the normal script kiddy scanning the internet
This does not make you more or less likely to be hacked just for having SSH open. But hey,go go gadget whatever.
As you said, only the low effort bots scan the standard ports.
But venture anywhere off the beaten path, and a place like shodan is the most benevolent of those kind of places, and it still takes about an hour for your IP and newly opened SSH port to be indexed.
Nobody is tracking 48 bits out of 128 bits and tying that to a specific user.
Pretty simple browser fingerprinting will get you much closer.
Not to mention that you know MAC addresses aren’t unique right. They only have to be unique on the same L2. And with some shipping logistics, you can make sure this is usually true.
I say this as a person who received a case of Intel NICs back in the day and every MAC was the same.
By any stretch of the imagination.
Very purposeful
Whether IPv4 or IPv6, it's trivially easy to grab a new one. And unless you are willing to start blocking huge swathes of the world and ultimately legitimate traffic, you do other things.
What you are talking about is RFC 4862. The SLAAC part of ipv6, which is auto-configuration.
What I am talking about is RFC 4941:
Privacy Extensions for Stateless Address Autoconfiguration in IPv6
Which is pretty close to:
"extension added later for privacy"
4862 < 4941