291 karma · joined November 12, 2018
I know it is an highly physical demanding and also very risky job. Now that a second child arives, obviously, life changing again, i just cant do it, i need to feed two kinds soon and these kind of jobs are not well payed.
So ill stick to doing my own firewood once a year, a couple of days outside in the woods and keep dreaming about it.
Live goes by too fast.
Of course the project consists of multiple module which you should be able to build seperately, thus recursive calls are quite common amongst the makefiles.
First test with only a hand full of jobs (-j) already failed in the beginning, i could fix these quite fast (missing makefile targets).
Now i have the situation that on some build systems (with faster CPU) i still see races, where the same makfile target for a subproject runs at the same time and overwrites each others target files. On other build systems it works without any issue. However, ive still failed to reproduce the failure manually, it usually happens during automatic build invoked by jenkins or gitlab.
Is there a way to make "make" simulate those builds so one could tell where the cause for the races is in detail?
https://arstechnica.com/civis/threads/winamp-really-whips-op...
theres already projects solving central ssh key management, for example:
https://github.com/ierror/ssh-permit-a38 (distributes via authorized keys)
https://github.com/netlore/OpenAKC
https://tenshidev.medium.com/centralized-ssh-authentication-...
and
https://docs.gitlab.com/ee/administration/operations/fast_ss...
Backing up a linux system in combination with REAR:
and a backup utility of your choice for the regular backup has never failed me so far. I used it to restore linux systems to complete different hardware without any troubles.
https://github.com/tasket/wyng-backup
edit: requires lvm thin provisioned volumes
There is also thin-send-recv which basically does the same as zfs send/recv just with lvm:
https://github.com/LINBIT/thin-send-recv
it uses the same functions of the device mapper to allow incremental sync of lvm thin volumes.
2) you push that container image to some registry
3) you use the bootc image container to create an qcow file from the image you have built (or you install the image on a bare metal system)
4) you boot up the virtual machine or bare metal system, which now includes "bootc" utilties too
5) from this point on you can update the container image you have created in step 1) and you automatically roll forward the booted virtual machine or bare metal system to the latest image you have relased (or rollback, if your updated image breaks stuff) using the included bootc utility
Currently the image that supports this seems to be limited to centos:stream9, or rhel9:
https://www.redhat.com/en/blog/image-mode-red-hat-enterprise...
So an direct attached lvm volume is the best solution performance wise. In the vmware world this would be an direct attached raw device either from local disk or SAN.
For fresh install on proxmox its better to chose qcow as disk image format with virtio-scsi bus (comparable to vhdx, vmdk, qemus disk format) and add virtio drivers during windows setup.
ive just put it here: https://github.com/abbbi/sqlitestress
maybe its useful for some people to simulate their workloads.
> But, my favorite feature of the gem is its improved concurrency support.
> [..] https://fractaledmind.github.io/2023/12/11/sqlite-on-rails-i...
Really. At the point you are experiencing database locked in your productive app that uses sqlite as backend, i would strongly suggest to use another database backend that was designed with concurrent writes in mind.
Nothing against sqlite in production, its nice, as long as your workload meets its feature set.
Want to spin up not only 1 but 20 instances via the console? Nope. Any kind of guest agent in the virtual machine? For direct interop? How is the guest filesystem freezed during snapshot creation? Checkpoints for incremental vm backup? They seem to use raw images, not qcow2? Why?
etc..
"A disk cannot be added or attached unless the instance is creating or stopped." "A network interface cannot be created or edited unless the instance is stopped."
really?