Wildcard certificates are only valid for the subdomain level directly under it. [1]
If I get a wildcard certificate for example.com (the common name is set to *.example.com), foo.bar.example.com will throw an error.
[1] https://en.wikipedia.org/wiki/Wildcard_certificate#Limitatio...