Just saying it is possible that this is an over-aggressive spam filter vs. Apple taking such an invasive measure. Although, Apple has done similar crazy things before, so who knows.
4.2.5 Reply Codes After DATA and the Subsequent <CRLF>.<CRLF>
When an SMTP server returns a positive completion status (2yz code)
after the DATA command is completed with <CRLF>.<CRLF>, it accepts
responsibility for:
- delivering the message (if the recipient mailbox exists), or
- if attempts to deliver the message fail due to transient
conditions, retrying delivery some reasonable number of times at
intervals as specified in section 4.5.4.
- if attempts to deliver the message fail due to permanent
conditions, or if repeated attempts to deliver the message fail
due to transient conditions, returning appropriate notification to
the sender of the original message (using the address in the SMTP
MAIL command).
If it's spam, the email should be rejected while the SMTP connection is still established with an error code (4XX or 5XX). If the email was accepted for delivery, there are really only two options: deliver the email or bounce it back to the sender."As discussed in Section 7.8 and Section 7.9 below, dropping mail without notification of the sender is permitted in practice."
You should REJECT a message if you won't deliver it. If it was a legit message inappropriately REJECTed, then the server that's relaying it can generate a bounce back to the sender, and something can be figured out.
Dropping a message on the floor like that, after you have promised to deliver it is almost always the Wrong Way.
Whether or not that's appropriate is another thing, but that is probably the rationale behind it.
This is news to me. Citation needed?
Anecdote: we use hosted Exchange from Microsoft. I tried to setup a cron job to email us all at 4:57 with the subject line "Get The Fuck Out". Those don't come through either.
And they don't respond to complaints, even from their own users.
I've been running the same pukka mailing list for 12 years, I'm in their abuse feedback loop, have proved exclusive ownership of the mail server, all mail is DKIM signed with valid SPF records, mail is accepted with a 250 OK, you name it.
Still they bin my emails, but only to some accounts. No rhyme or reason, no bounce, no spam folder. Just never arrives.
You could also reasonably configure a filter to not land emails over a spam threshold.
Given the amount and type of spam in my Gmail Spam label, I'm quite sure there's a hard filter in place there too.
So it could be a bug in their definitions files.
I'm going to take a guess that this is just a misconfiguration in the spam filters.
A misconfiguration in your email server that results in emails being silently dropped is about as bad of a misconfiguration as you can have. That shouldn't even be an option to configure.
I just remember there being debate/discussion about this before.
http://blogs.msdn.com/b/tzink/archive/2011/08/09/why-silentl... http://en.wikipedia.org/wiki/Non_delivery_report#Silently_dr...
"As discussed in Section 7.8 and Section 7.9 below, dropping mail without notification of the sender is permitted in practice. However, it is extremely dangerous and violates a long tradition and community expectations that mail is either delivered or returned. If silent message-dropping is misused, it could easily undermine confidence in the reliability of the Internet's mail systems. So silent dropping of messages should be considered only in those cases where there is very high confidence that the messages are seriously fraudulent or otherwise inappropriate."