Talk to me about this, "Since the nonce will already have been consumed by the first request, the second request will be rejected."
What if the nonce was still valid for the second response because your server detected that the connection was dropped for the first response?