allowed-ips: [0.0.0.0/0, "2001:fe:ad:de:ad:be:ef:1/24"]
Note that the IPv4 addy didn't need the double quotes, but the IPv6 addy did.The parser should have picked this mistake up, and the server shouldn't have been crippled to the extent of needing a rescue.
More docs seen here: https://netplan.readthedocs.io/en/latest/netplan-yaml/
Perhaps the trap is the complacency that YAML induces by not requiring quotes around keys/values, and so text risks being interpreted in unexpected ways. The infamous Norway Problem has the same root cause.
This is incorrect. The colon needs to be followed by whitespace for it to indicate a key-value pair. You can check this with the reference parser (and a bunch of others!) online: https://play.yaml.io/main/parser?input=YWxsb3dlZC1pcHM6IFswL...
I bet the parser did actually fail, because you can't parse a misformed dictionary into a string. Your problem is that the tool probanlt took down the interface before trying to parse for format, and then failed to bring the interface back up.
Similar to bogus data in /etc/network/interfaces, resetting the network interfaces with bogus data will end up with your server having no or limited connectivity capabilities.
At least with YAML there are command line parsers available to check your work. Plaintext config files often end up being a game or chance to see if you've got the format right.