Any standard email host with IMAP access and a custom domain will do. I like Migadu.
The other oddity is that the expect you to set up the DNS records before they active inbound mail on the account. This means that in order to get set up you will need a period where mail is rejected. However by reaching out to support I could get them to active the account first, then I could add the records for a zero-downtime migration.
Other than that the service looked really good.