We really need to fix email, it shouldn't be this hard -_-
We really need to fix email, it shouldn't be this hard -_-
Some years back I got most of personal mail sent from my server randomly rejected by Google. Dropping the blog newsletter was one of the things I did (the other was some fixes to my DKIM/DMARC setup that I think were suggested to me here on HN). I was sending the newsletter from a different server, but used the same DKIM domain and the same domain in From:. It was suggested to me that the newsletter could have been the cause for blacklisting.
The newsletter was strictly opt-in through a form on my page and only had around 10-20 subscribers. It had a hard limit of at most 1 message per week. I think I was running it for around 3 years when I shut it down.
Probably nobody knows what the true reason was, but some time after these changes I was able to send mail to @gmail.com domains again.