Even when you log in via ipv4, and make relevant networking changes (basically enabled DHCP for v6), it will still fail to apt-get update, because eu-central-1.ec2.archive.ubuntu.com is ipv4-only.
Sad.
Even when you log in via ipv4, and make relevant networking changes (basically enabled DHCP for v6), it will still fail to apt-get update, because eu-central-1.ec2.archive.ubuntu.com is ipv4-only.
Sad.
If you disable IPv4 entirely, then it's true that you won't be able to access the archive mirrors. However, this isn't exactly "out of the box". :)
If you do want to disable IPv4, then at the same time you'll also need to modify your /etc/apt/sources.list to point at archive.ubuntu.com (which does serve over IPv6).
We're looking at how we can best make the "no IPv4" case work with the in-cloud mirrors, and hope to have that resolved soon.
So I'm guessing that was the issue here.
Prior to that dhclient fix, dhcpv6 was basically unusuable on 16.04.