HNHacker News
TopNewBestAskShowJobs

grkvlt

1,544 karma · joined May 10, 2012

distributed systems hacker.

open source contributor to hyperledger sawtooth and seth, apache brooklyn, jclouds and qpid; enterprise software engineer; java, big data, cloud, security, open source, distributed systems, messaging, virtualisation, lolcats.

    mailto:andrew.kennedy@cloudsoft.io

    https://github.com/grkvlt
    https://twitter.com/grkvlt
    https://speakerdeck.com/grkvlt

    https://abstractvisitorpattern.blogspot.co.uk/
    https://grkvlt.blogspot.co.uk/
submissionscomments
grkvlt··on The US Dollar Could Outlast the American Empire
Or maybe they are just talking about EDs or https://en.wikipedia.org/wiki/Eurodollar (although they are just dollars held outwith the juristiction of the Federal Reserve, and I can't remember if they are meant to be the thing in the games)
grkvlt··on Cameras and Lenses
It's more that the rays from a point on an object converge to the smallest point when in focus? The rays from the object as a whole are spread out over an object-shaped are on the image plane, unless the object is (effectively) at infinity, when they will converge to a point...
grkvlt··on A creature that eats its own brain
I noticed that too; hopefully in the intervening 7 years these sorts of limitations are no longer, but I suspect scientific data simply expandss to fill the archive space available, and more ;(
grkvlt··on Satellite warfare: An arms race is brewing in orbit
is there a good metric for distance between two objects in different orbits? you can say something like "must not come within x km of each other for the next n years" but extending that to all orbiting object pairs seems complex. i may be overthinking this, though?
grkvlt··on Low-Background Steel
Just search for the paper on the topic, written by the Phillip Morris Unbiased Research Group. it explains how frogs breathing air got more cancer then frogs trapped in airtight boxes and only allowed to breathe exhaled tobacco smoke, who mostly died for other reasons. seems legit...
grkvlt··on Drug cartel ‘narco-antennas’ make life dangerous for Mexico’s repairmen
ok, these are all good points, perhaps i could have been clearer. how about this, which i think is a true statement based on my understanding; drugs (mostly cannabis) are usually only decriminalised, rather than legalised, due to treaty obligations within the un system. this makes canada (and uruguay) interesting cases, since both have actually legalised cannabis.

sure, there won't be a un police action against them, and today i learned that denunciation is an option in the relevant treaty, rather than expulsion. but, there is a good reason (treaty obligations) why countries won't just 'legalise all the things' and have traditionally followed softer approaches.

grkvlt··on Drug cartel ‘narco-antennas’ make life dangerous for Mexico’s repairmen
in fact, legalization of class A or B (schedule 1 and 2 in the USA) drugs would generally mean expulsion from the UN of that country for breach of the charter. that's why e.g. the Netherlands have only decriminalised certain drugs. technically they are still illegal. in fact, if Canada was a smaller, non Western/developed country, im sure they would not have legalised cannabis, and even so they definitely won't legalise wholedale trafficking etc. it seems the UN got a bit upset but couldn't do much? [0]

0. https://news.un.org/en/audio/2018/10/1023212

grkvlt··on British Airways announces immediate retirement of 747 fleet
it's easier than you might think. for example, on a 747 you don't need external stairs, since access is available via the nose wheel landing gear bay [0] according to a pilot.

0. https://aviation.stackexchange.com/questions/2605/can-large-...

grkvlt··on British Airways announces immediate retirement of 747 fleet
i stopped counting at 15 (over a dozen) cities in this list [0] and had just finished the letter c so there are scheduled a380 flights to many more destinations than you imagined...

0. https://www.iflya380.com/a380-destinations.html

grkvlt··on British Airways announces immediate retirement of 747 fleet
not really. the a380 was designed to be able to use any airport which could service a 747 (so no widening or lengthening of runways etc) and airbus were betting ON the hub and spoke model remaining dominant, which didn't happen, and point to point flights between regional airports became the norm instead with the 787 etc being used to services them.
grkvlt··on Boom supersonic jet readies for rollout
quadcopter aircraft scale up fine, for example the bell x-22 [0] research vehicle.

0. https://en.wikipedia.org/wiki/Bell_X-22

grkvlt··on Boom supersonic jet readies for rollout
a sonic boom is a phenomenon that occurs continuously when traveling over mach 1.0 so supersonic flight is usually limited to over water routes and forbidden over or near urban areas.
grkvlt··on Boom supersonic jet readies for rollout
that's true of LHR as well, there is a Concorde Room just after the priority security scan lane, and first class or top tier BA pax get invited. the place is insane in terms of 'premium-ness' with the experience being s whole level above the usual BA first class lounges - you'll find the full details on the ba.com site. sadly i only managed to use it once or twice, when my boss guested me in ;(
grkvlt··on Boom supersonic jet readies for rollout
im guessing if you really need, and can afford, supersonic travel then either it'll be like flying business/first or you'll have top tier ff status with the airline, and queues etc are much less of, or even a non issue.
grkvlt··on The NSA called me after midnight and requested my source code (2018)
I wouldn't worry. You can still set up a computer pretending to offer a DoD login, in fact as many as you want/can afford on AWS, and you still won't go to prison. IANAL, but go ahead and knock yourself out! It'll be fun/character building/a learning experience no matter what happens.
grkvlt··on Ok Google – it's time you discovered cyclists
Well, miles andc metres is basicallyh identical to miles and yards, so it's not that weird...
grkvlt··on Ok Google – it's time you discovered cyclists
> It doesn't appear to factor in aspects unique to cycling, for instance difference in elevation, when calculating the best route.

This quote is followed immediately by a screen capture showing the text 'Mostly flat' underneath the journey time and distance.

In fact in Edinburgh, UK my experience with Google Maps has been that it automatically selects routes that use more cycle paths, roads with cycle lanes, and flatter or downhill options. Maybe this is different per city?

grkvlt··on Coronavirus Spike Protein Binder Design
In the UK there is the Wellcome Trust [0] which is a non profit healthcare research body, and I believe other organisations like this exist. They would seem to be the ideal place for this type of work?

0. https://en.m.wikipedia.org/wiki/Wellcome_Trust

grkvlt··on Later school start times are associated with more sleep and better performance
Except, kids in the UK seem to manage fine. Here, both primary (4/5 to 11/12) and secondary (12/13 to 17/18) start at 09h00 and have done so for a long time with no detrimental effects. Although, there are apparently plans for some secondary schools to instead start at 10h00, so there is that...!
grkvlt··on Report to local authority in the UK if you see a kid using Tor, VMs, Linux etc.
no, they don't. anyone who took more than 30s to read further than the headlines would see that this is an example of a set of checks for users of TAILS and points out that extremists often use this. its pretty obvious they don't consider linux journal in its own a sign of extremism.

these would be refined to be more useful and then used together to check for TAILS_terms in a user's emails and they are also accessing TAILS_websites and then in conjunction with other flags to find POIs.

grkvlt··on VMware Acquires Carbon Black for $2.1B and Pivotal for $2.7B
"Software Engineering" Why make anything anymore when you can do tricks with ones and zeroes, for money?
grkvlt··on How I got my username on nearly every site
His account has a published package available that was pushed about 3 months ago - hardly dormant, and based in their disputes process [0] it seems unlikely anyway:

> To dispute a user name [...] After 4 weeks, if the owner has not responded, support will address your request. The ultimate outcome is at their discretion and judgement.

And this statement on squatting confirms that it would be 'extremely unlikely':

> We are extremely unlikely to transfer control of a user name, as it is totally valid to be an npm user and never publish any packages: for instance, you might be part of an organization or need read-only access to private packages. If a user has not logged into their account in a long time, we may consider transferring a name if it is requested by a new user.

0. https://www.npmjs.com/policies/disputes

grkvlt··on Florida couple wins the right to plant veggies in front yard
And an enormous yard, at least if you really mean to grow over 50% of the food required for a family of four people, which will take about an acre (or 4000 m^2) i.e. more than four times the usual front lawn space in a suburban home.
grkvlt··on CNLabelContactRelation​YoungerCousin​MothersSiblingsDaughter​OrFathersSistersDaughter
And, in fact, CN has never referred to Chinese - it's an ISO two letter country code abbreviation for the PRC, admittedly - but the ISO two letter language code would be ZH for the Chinese language.
grkvlt··on Why people confess to crimes they didn’t commit
As with all things like this, it's complicated.[0]

It used to be the case that the right did not exist, but there are now provisions that allow cross-border arrests under 'urgent' circumstances even if there is no arrest warrant. This is confounded by the fact that some crimes do not exist or have different names or are classified differently. So, if I was North of the border in possession of an air rifle without a license, and was then chased by a Scottish Constable across the border into England, well... I have no idea if they could then detain (that is, arrest) me, since in England air weapons do not require a license. Anyone curious about this should try the experiment and report the results...!

0. https://assets.publishing.service.gov.uk/government/uploads/...

grkvlt··on Why people confess to crimes they didn’t commit
I mentioned this in another comment - only in England, Wales and Northern Ireland is it true that silence can be held against you. In the other constituent part of the UK, Scotland, there cannot be any adverse inference drawn from your silence.
grkvlt··on Why people confess to crimes they didn’t commit
Simple advice, yes. I would disagree on the 'easy to follow' part - it's very difficult to stand your ground against someone with the authority and powers of a police officer, especially in a tense or confusing situation. Alternatively, perhaps the officer is presenting things as a completely innocuous situation, where only someone like a sociopathic, unhelpful criminal with something to hide would refuse to respond, and so on. It makes it very psychologically demanding and emotionally draining to keep saying 'no comment' and yet still remember that you are doing the right thing and absolutely have the right to keep doing so.
grkvlt··on Why people confess to crimes they didn’t commit
And note that within the UK there are some big differences! The wiki link in the parent comment is for the England and Wales version of the police statement made at time of arrest, which points out that:

> You do not have to say anything, but it may harm your defence if you do not mention, when questioned, something which you later rely on in court. Anything you do say may be given in evidence.

But in Scotland, which has a slightly different (and obviously, of course, much better) legal system, the police statement is:

> You are not obliged to say anything but anything you do say will be noted and may be used in evidence.

The difference is due to the fact that under Scots Law, no adverse inference can be drawn based on a persons silence.

I am not a lawyer, but I would assume that they would recommend getting arrested in Scotland, rather than England, if you absolutely must commit crimes in the UK...

grkvlt··on RFC-1149: IP over Avian Carriers
Only from clients supporting HTTP only. Note that RFC 2324 [0] defines the Hyper Text Coffee Pot Control Protocol or HTCPCP, which is an extension of HTTP and implementors of clients for this are free to return 418 if necessary. Also, RFC 7168 [1] which extends the protocol as HTCPCP-TEA now fully supports teapots, and is probably a better choice for modern clients. Also of interest is the SNMP MIB for remote management of 'Drip-Type Heated Beverage Hardware' which is defined in RFC 2325 [2] although this does not appear to have been updated with teapot, samovar, urn or other non-filter-coffee management data...

Implementing tea making device remote management would probably be a good candidate for a GSoC project or even a startup if you can find a VC gullible enough to fund you!

0. https://tools.ietf.org/rfc/rfc2324.txt

1. https://tools.ietf.org/rfc/rfc7168.txt

2. https://tools.ietf.org/rfc/rfc2325.txt

grkvlt··on RFC-1149: IP over Avian Carriers
See also the famous quote about the bandwidth of a pickup truck filled with magnetic tape... The modern equivalent would be AWS Snowmobile [0] which is described as follows:

> Each Snowmobile is a secured data truck with up to 100PB storage capacity that can be dispatched to your site and connected directly to your network backbone to perform high-speed data migration

A Wired article [1] calculated the San Francisco to New York bandwidth of a full Snowmobile as just under 5 Tbps which is pretty damn impressive, although the offload network connection on the truck is (only) a 1 Tbps connection. And it gets quite pricey, a fully loaded Snowmobile is USD 500K per month, plus the 350 kW of electricity it needs.

According to the FAQ, if you need more bandwidth, you can operate the Snowmobile trucks in parallel to get multi Exabyte scale data transfers, but I have difficulty imagining any of the use cases that would require that as a solution...?!?

0. https://aws.amazon.com/snowmobile/faqs/

1. https://www.wired.com/2016/12/amazons-snowmobile-actually-tr...

← PreviousPage 4 of 34Next →