HNHacker News
TopNewBestAskShowJobs

esbranson

437 karma · joined January 3, 2014

https://twitter.com/esbranson

https://github.com/esbranson

submissionscomments
esbranson··on Understanding Traceroute
tracepath on Linux does not need the CAP_NET_RAW capability (or full root capabilities) during network data processing because it relies on the Linux socket error queue behavior. I assume traceroute on OpenBSD opens all required sockets and immediately drops privileges.
esbranson··on Move Detroit
Its metropolitan area major economic indicators still look brutal. Its peak unemployment rate was almost 24% during COVID when its labor force participation rate went to 43.5%. That means only 33% of adults were employed in periods during COVID...

Now it is closer to 46.6% of adults working. That's the best of times for the Detroit area.

esbranson··on US cities are axing Flock Safety surveillance technology
A crime drop between over that 3 months is not, as evidenced by the subsequent rise for 3 months after, of the time period you claim as evidence.
esbranson··on IPv6 is the only way forward
mDNS is orthogonal to ULA. mDNS is for discovery and name resolution, whereas ULA is for IP connectivity. And mDNS operates at the link-local scope (link-local addresses), whereas ULA is scoped for the entire home network.
esbranson··on IPv6 is the only way forward
RFC 7368 for home networks recommends the use of ULA locally.

> A home network running IPv6 should deploy ULAs alongside its globally unique prefix(es) to allow stable communication between devices (on different subnets) within the homenet

> When an IPv6 node in a homenet has both a ULA and a globally unique IPv6 address, it should only use its ULA address internally and use its additional globally unique IPv6 address as a source address for external communications.

esbranson··on IPv6 is the only way forward
Unmentioned in the Wikipedia article is RFC 7368 IPv6 Home Networking Architecture Principles[1] that discusses them as well.

> A home network running IPv6 should deploy ULAs alongside its globally unique prefix(es) to allow stable communication between devices (on different subnets) within the homenet

[1] https://datatracker.ietf.org/doc/html/rfc7368.html#section-2...

esbranson··on IPv6 is the only way forward
And I know the homenet WG has concluded but I found RFC 7368 IPv6 Home Networking Architecture Principles[1] interesting as well, including its discussion of reachability and RFC 6092 Recommended Simple Security Capabilities in Customer Premises Equipment (CPE) for Providing Residential IPv6 Internet Service.[2] IPv6 still occasionally seem more flaky than IPv4 with some set ups though.

[1] https://datatracker.ietf.org/doc/html/rfc7368.html#section-3...

[2] https://datatracker.ietf.org/doc/html/rfc6092

esbranson··on US cities are axing Flock Safety surveillance technology
> Would crime go up, down or stay the same if all surveillance cameras were removed?

I would think the same, crime rates would be unaffected in the short and medium term, since I don't think it prevents much crime given the short or non-custodial sentences given many criminals. Clearance rates and justice (conviction rates) would likely go down though IMO.

esbranson··on US labor force participation continues to slide
The biggest issue is tertiary (post-secondary) education and its effect on the LFPR in that age range, but not the prime age LFPR.
esbranson··on US labor force participation continues to slide
> In November 2023, the labor force participation rate reached 62.8%

In November 2023, the prime age (25-54 years old) labor force participation rate was 83.4%.[1]

> At the same time, the labor force participation rate edged down from 62.0% in February to 61.9% in March, the lowest level since November 2021.

The prime age LFPR was 83.9% and 83.8% in February and March 2026, and 82% in November 2021.[1]

The prime age labor participation rate is just about the highest it's ever been in recorded history. The gender gap is also the lowest it's ever been.[2]

[1] https://fred.stlouisfed.org/series/LNS11300060

[2] https://home.treasury.gov/news/featured-stories/spotlighting...

esbranson··on German implementation of eIDAS will require an Apple/Google account to function
Verifiable credentials (VCs) are W3C standards and do not involve blockchains. Nor does Web 3.0.
esbranson··on Quad9 Enables DNS over HTTP/3 and DNS over QUIC
Excellent. Since privacy and cybersecurity are goals, TLS Encrypted Client Hello (RFC 9849, ECH) and its DNS service bindings (RFC 9848) were finalized last month.
esbranson··on I prefer OG style websites – what are yours?
RSS (RDF Site Summary), released in 1999-2000.

Because I don't want to deal with formatting, I want to focus on data. Firefox and Safari formatting looked great.

esbranson··on I'm betting on ATProto
The Fediverse did take off. Then large numbers of influential people got banned by randos and realized how much better and reliable (non-profit or not) corporate censors are.
esbranson··on Why I'm betting on ATProto (and why you should, too)
Is the same algorithmic connectivity with Japanese happening on Bluesky as it is on Twitter, or are Bluesky's algorithms just as opaque as Twitter's?
esbranson··on Why I'm betting on ATProto (and why you should, too)
I was disappointed by the hard divergence from core aspects of Tim Berners-Lee‘s vision (and its current implementations) of a Web 3.0 but oh well. Threads got on board, and it’s not to say the missing parts can’t be bolted on later. In particular any future W3C Linked Web Storage WG protocols.[1]

[1] https://www.w3.org/groups/wg/lws/

esbranson··on Spanish legislation as a Git repo
OpenAI, Anthropic, and Google are way ahead of you. Ask your heart away. I am unsure about open source models, it'd be interesting to know if they're ingesting the law.
esbranson··on Spanish legislation as a Git repo
Have at it!

The reality is that the official United States Code gives plenty of history for statutes, while the Code of Federal Regulations gives less but still basic history. Both are also provided in XML in bulk, though the former has a modern USLM format and the latter has an archaic schema. Case law is less amenable to git histories.

esbranson··on Spanish legislation as a Git repo
CourtListener (from the non-profit Free Law Project) provides bulk access to its case law collection.[1][2] I expect they are ingesting the GPO uscourts collection so it should have near complete (99%) coverage.[3][4]

[1] https://www.courtlistener.com/help/api/

[2] https://www.courtlistener.com/help/coverage/

[3] https://www.govinfo.gov/help/uscourts

[4] https://www.courtlistener.com/help/coverage/opinions/

esbranson··on Quantum frontiers may be closer than they appear
Common sense?
esbranson··on Quantum frontiers may be closer than they appear
There is no billion-dollar annual market for quantum compute usage in private industry. Yet these companies are getting billions, and it ain't all grants, stocks, bonds, and notes. Ain't rocket science.
esbranson··on Order Granting Preliminary Injunction – Anthropic vs. U.S. Department of War [pdf]
Yes, more of this. (Direct, timely links to court dockets and documents on US Article III court cases.)
esbranson··on Judge blocks US Government from slimming down vaccine recommendations
American Academy of Pediatrics v. Kennedy (1:25-cv-11916)

https://www.courtlistener.com/docket/70722326/291/american-a...

esbranson··on When I lost my university email, my identity as scientist took an unexpected hit
Community college email accounts FTW. Support your local district.
esbranson··on Pentagon's Anthropic Designation Won't Survive First Contact with Legal System
Lawsuits are posturing. Nowadays opening briefs read more like polemics.
esbranson··on Pentagon's Anthropic Designation Won't Survive First Contact with Legal System
> Based on the public record, it's unclear

First section summary. This is an X post.

> First, the bar covers actions "under such authority"—meaning actions that exceed the statute's grant fall outside it entirely.

The authority, which is omitted in the article, is likely the subsection entitled "Authority". Who woulda thought. (a) Authority.—…(1) carry out a covered procurement action; and (2) limit, notwithstanding any other provision of law, in whole or in part, the disclosure of information relating to the basis…. There is no mention of "was built to address foreign adversary threats to the IT supply chain" in the aforementioned authority. The rest reminds me of sovereign citizen arguments: good luck lol this is about military procurement.

> "Adversary" is undefined, but

This holds more water. Too bad the court will be prevented from reviewing the underlying record with which to decide, for a coequal branch, who are adversaries. And unlike IEEPA, their declarations are not in the Constitution.

> Pretext

The underlying record, and their decision to "limit" disclosure (not "not to disclose"), is unreviewable.

> the required findings don't hold up

Dang, ignorance of "no action … shall be subject to review" is doing real work. It does not matter if only the record cannot be reviewed. If a court cannot review the information, it cannot make contrary decisions.

esbranson··on Libxml2 Enterprise Edition (AGPL, from the previous maintainer)
The corporate freeloading issue must be resolved somehow.
esbranson··on Ministry of Justice orders deletion of the UK's largest court reporting database
There is no way to verify if European countries have rule of law without insight into their courts.
esbranson··on Palantir Gets Millions of Dollars from New York City's Public Hospitals
HHC, a Democratic Party-controlled state corporation, with the NYC administrator of health services as its chairman, is selling health data. Which is ok as long as it's not Palantir or the elected government, apparently. (The elected governments that run the systems.) Get off your high horses, any faux outrage does not fool many.
esbranson··on Palantir Gets Millions of Dollars from New York City's Public Hospitals
HIPAA privacy arose indirectly from its administrative simplification provisions concerning its main goal of standardized electronic health data. Privacy is not "why HIPAA exists".
← PreviousPage 3 of 20Next →