In particular, there are enough stacks that ignore it that it would be unsafe to issue a CA certificate even with nameConstraints.
X509 extensions can be marked as critical. Certificates must be rejected if the stack encounters a critical extension it doesn't understand. (In theory at least, I haven't looked at real implementation behaviour.)
So then you've jumped from the frying pan into the fire, since your cert now will not work in those implementations.