> All events on the node was stalled so I could not boot down or take an image to spin up a new instance.
This should not surprise you. This is a common failure method of VMs. So, let's say a host was down. Depending on their storage methods, this means that the all the images on the disk are inaccessible. This means that you can't interact with it, which is why you couldn't take snapshots.
> Had to hammer their support with a dozen ticket before someone didn't just give me a canned reply.
Abusing support is never the right answer, I'm not surprised you only got canned replies.
> I like DO but stuff like this just can't happen without anyone checking on it stat.
It's almost like every problem cannot be solved instantly.