That would be awesome. I fooled around with it and failed. I created a user with S3 full access (I have nothing else using S3) and it complains that access is denied.
Here you go! Please let me know if you encounter any issues or if anything is unclear. Any and all feedback is absolutely appreciated!