AT&T put an optic cable at my curb 10 years ago (most likely due to imminent competition from Google Fiber internet), but then never lit it (most likely because Google dropped their effort due to complications with cities)…
AT&T put an optic cable at my curb 10 years ago (most likely due to imminent competition from Google Fiber internet), but then never lit it (most likely because Google dropped their effort due to complications with cities)…
For me personally, I work on networking startup so I'd like to be able to run IPv6 stack from my home network to test things.
Another feature that I find to be pretty stupid (but that some folks seem to really like) are IPv6 "privacy" addresses. Because each host usually is assigned an IPv6 address in a subnet that's 64 bits wide, most mainstream OS's have configured their IPv6 address autoconfigurator to set one stable, "permanent" address, and to set a parade of periodically changing "temporary" addresses. The OS is usually configured to prefer the permanent address when software asks for a socket to listen on (and sockets that handle replies to that listen socket), and those temporary addresses are preferred for sockets that initiate outbound traffic. The idea is that this is supposed to confuse tracking, but I'm very skeptical of its efficacy in the real world.
Finally, a customer can also usually get enough IP space to make globally-reachable subnets on their LAN. Depending how the ISP has configured things, a customer can get between four and 256 subnets. These subnets are handy to provide networks that provide globally-reachable IP addresses, but that can be easily logically isolated from the rest of the LAN by the router.
IMO, something like what's described in RFC 7217 [1] (changing the interface identifier used for "permanent" addresses from the interface's MAC address to something that mixes in the advertised prefix) is a much better way to address the concerns described in section 2.3 of RFC 4941.
[0] <https://datatracker.ietf.org/doc/html/rfc4941#section-1.2>
[1] <https://datatracker.ietf.org/doc/html/rfc7217#section-4>
VPNs: Business IT usually uses some weird IP range like 172.xxx.xxx.xxx so avoid conflicting with the popular 192.168.1.xxx or 10.xx.yy.zz. When two companies merge there is now an IP range overlap and a renumbering has to be done.
P2P file transfers: No port forwarding needed.
Self-hosted servers: No port forwarding needed.
Video chat/VoIP: One reason video chat still suffers from bad quality is that video is proxied through cloud servers to deal with NAT. With more IPv6 video chat services can use more direct connectivity lowering costs and improving quality.
Avoiding CGNAT. If anyone on the same CGNAT group in your ISP got banned you will also be banned. Many Internet services don't have IPv6 and they often cite IPv4 based reputation as the reason why they won't deploy IPv6.
That has nothing to do with OP's question about consumer internet concerns. However, I've been through several corporate acquisitions. The thing that took the longest to work out? Getting the new company's name on the paychecks.
The thing that took the second longest to work out? Renumbering networks and consolidating and decommissioning hardware for which there just wasn't enough RFC 1918 space available. Every. Damn. Time. this process dragged on and on and on, when IT could have saved 6->18+ months of future work [0] by generating a /48 ULA and using that for every internal thing but the stuff that was IPv4-only.
[0] ...and god only knows how many dollars in labor costs...
Also the Sail support is really good, fast responses (even the CEO sometimes answers tickets).
I have been a customer for 14 years now. Would love to move to higher bandwidth.
I recently moved into Menlo Park and had no problems getting 2.5Gbps from ATT fiber.