Not allowed for gTLDs. Some ccTLDs do it, http://ai/ resolved as recently as a year ago though I can't get it to right now.
It’s unreachable anyway
[0]: https://jvns.ca/blog/2022/09/12/why-do-domain-names-end-with...
man resolv.conf, read up on search domains and the ndots option
http://uz./ serves a 500 error.