It seems we either ate all your LLM credits or knocked your server over since the spinner just spins (checking dev tools coughs up that https://app.fluentsubs.com/api/exercises/daily?language=fr is 504)
After 4 retries, the spinner finally gave up but it incorrectly said "Sorry, no exercise available for this language today." and not, as it should have, "We were unable to load the exercises. Try again later, or contact support at ${email}"
---
The AppSec-er in me wants to point out that returning the version of nginx that you're using is an antipattern since it enables more targeted attacks if the version has woes; it does it in the error, and it does it in the headers