Doesn’t fully convince me as having a single physical server is very different than a managed DB. If you have a disk failure you will be down until that is resolved. Which is in fact the exact scenario that happened to a client of mine and which led me to migrate to the cloud