> intr / nointr
> Selects whether to allow signals to interrupt file operations on this mount point. If neither option is specified (or if nointr is specified), signals do not interrupt NFS file operations. If intr is specified, system calls return EINTR if an in-progress NFS operation is interrupted by a signal.
> Using the intr option is preferred to using the soft option because it is significantly less likely to result in data corruption.
But:
> The intr / nointr mount option is deprecated after kernel 2.6.25. Only SIGKILL can interrupt a pending NFS operation on these kernels, and if specified, this mount option is ignored to provide backwards compatibility with older kernels.
So I guess on Linux you just have to use "soft" now instead[1]. (I believe intr still works on FreeBSD, which is the last place I made significant use of NFS[2].)
> soft / hard
> Determines the recovery behavior of the NFS client after an NFS request times out. If neither option is specified (or if the hard option is specified), NFS requests are retried indefinitely. If the soft option is specified, then the NFS client fails an NFS request after retrans retransmissions have been sent, causing the NFS client to return an error to the calling application.
> NB: A so-called "soft" timeout can cause silent data corruption in certain cases. As such, use the soft option only when client responsiveness is more important than data integrity. Using NFS over TCP or increasing the value of the retrans option may mitigate some of the risks of using the soft option.
[0]: https://linux.die.net/man/5/nfs#:~:text=the%20NLM%20protocol...
[1]: https://linux.die.net/man/5/nfs#:~:text=soft%20/%20hard,the%...
[2]: https://man.freebsd.org/cgi/man.cgi?query=mount_nfs&apropos=...