It's been fixed. Send Content-Type: application/xhtml+xml and it will be parsed as an empty tag. But nobody brothers to turn that on. Without an opt-in it's unfixable due to backward compatibility.
Why would it be a bug in the spec? “/“ is just a parsing error in html and is ignored.