I'm used to cloud VMs where if one dies, I can quickly spin up another one effortlessly (I never have to contact support or anything like that).
I'm used to cloud VMs where if one dies, I can quickly spin up another one effortlessly (I never have to contact support or anything like that).
Some failures I experienced and had to monitor/detect myself were: overheating (they replaced thermal paste when I told them I saw strange readings from the CPU stats), raid disk failure or ssd high burn (ie. partial failure, server still running, they replaced the failed disks after I told them).
Most of the time the issues have been resolved within 1-4 hours on low-cost Kimsufi and SoYouStart offers, even on weekends and nights. Often when the server is running they can require a shutdown.
I'm quite happy with this as I am highly technical in those subjects and like to look under the hood, but with dedicated servers you really have to do some more maintenance/monitoring/planning yourself.
> They don't monitor other health issues however (how would they since you are running your own system?) and therefore don't do anything before they detect a "down" status.
My server has a hardware raid card. I have had one incident where OVH contacted me and said there was an issue with one of the drives, and that they will reboot the server at X time to replace it. They did so, and the problem was solved with no requests or intervention on my part.
I had another incident where I was told the motherboard died. IIRC, it died around 1am my time and was replaced by 5am my time. They of course turned the system back on for me. I was asleep the whole time, and this was likewise solved with zero requests or intervention on my part.
Besides this, I can count the number of times an internet or power issue made my server unreachable on a single hand. IMO, a great experience for a dirt cheap host.
That all being said: OVH's ipv6 solution is laughably bad and is the single reason why I would switch hosts, if a better one with a north American presence appears.
But somes issues are not failures and you have to work on them on your side.
Most of the time the raid is software nowadays for example.
IPv6 works fine for my many servers at OVH.
But they often go even above and beyond for you. I rent several servers from them for many years, and I've had it happen once or twice that I got an e-mail from their datacenter team telling me that they noticed an error LED blinking on one of my servers, and actively offered to plan a repair intervention. All I had to do was to come up with a downtime window and communicate it to them. Very slick.
I'd say about half of overall value of Hetzner is in their quality support.
I showed them the sudden loss of power events in the logs. "It must be a problem with your OS modifications that we don't support".
OK, I wiped the machine to the stock image that you provide and it's still having power loss events. "Sure, we'll run a stress test for a couple minutes ... stress test passed OK, it's still your fault!".
The events happen randomly during the week, a stress test is not going to show that. Can you just move me to a different physical machine? "No."
This was over the course of several days, when I had an event coming up that I NEEDED the server for. I ended up going back to Azure and paying 10x the cost, but at least it worked great.
https://i.imgur.com/3DKc9OC.png
I have never seen this page before when trying to login. Make of that what you will.
That's some dedicated client response team if so!
Provisioning of servers was always quite fast. Same day or the next business day.
My experience is a little dated, I used to order bunch of dedicated boxes from them for our clients and with Hetzner we always had the best experience. Also the most bang for the buck.
Then you contact support, appoint disk change, you first deactivate disk on raid (save geometry etc), they replace disk and then you rebuild raid in new disk. That's it. With SSD you may not even need to do this anymore.
I imagine this would take time, right? Like not 5 minutes, but maybe 3 hours top? So, if I pretend to run a saas (that shouldn't be down more than 1h/day), then renting only 1 dedicated server could be qualified as "risky"?
They will all be hot-swap disks. You remove the old disk and slide in the new one (or in this case, tell them to do it). The RAID system rebuilds the array in the background over the next few hours.
During that time you will lose data if it's RAID 5 and another disk fails.
mdadm --manage <array> --remove <failed disk>
so your machine doesn't have a fit when the disk is detached. Or equivalent.
For example I have loads of stuff on Linode but always make sure I keep backups off-linode, incase I get a random TOS account shutdown and they stop speaking to me etc