not so fast... young unicorns !!
Where are you going to log the nasty errors when it fails.
You probably want to setup a self-hosted cloud-based remotely-managed splunk and ensure someone does the maintenance/upgrade for you (those can be challenging)
Have you properly setup your pager-duty ? I wouldn't want to miss one of the cron execution !!