I understand the server is having difficulties, but this is the first time I see "406 - not acceptable" in the wild. I expected it to throw a 500 error or just timeout.
We still don't know what broke here - the Cloudflare worker or Webflow, or the combination of the two.
That's the best logic I can discern here. I honestly have no idea.
My guess would be that whatever abstraction they used ended up with no content produced (because of timeout or whatever) so the framework could not satisfy any of the content types that the client accepts. Still another error would be better but I can see how it could happen.