RFC.fyi: Browse RFCs by keywords, id or collection
rfc.fyi
rfc.fyi
I want my Back and Forward buttons working. Especially on this site, which has no other means to clear the query.
Out of the 45 search results, the most relevant one (the UDP RFC itself) was all the way at the bottom, listed as "RFC0768" and tagged as "legacy". (I'm not sure what legacy actually means here?)
Anyway, I clicked the link, which took me to a 404 error page - https://www.rfc-editor.org/rfc/rfc0768.html (The correct URL is apparently without the leading 0)
This site does seem genuinely useful, but I think the UX could really use some polishing here, especially since I literally followed through with one of the example queries in the middle of the homepage.
Today a document like RFC 768 would most likely be the product of an IETF Working Group (possibly after being initially drafted outside and then adopted). In some cases an Area Director might authorise somebody to write a document without the Working Group process under their direct sponsorship instead. Together these form the IETF stream. This stream is the only means by which the IETF produces "standards track" documents, although it can also produce other documents from this stream.
Two other related groups, the IAB and IRTF, might create documents the RFC Editor cares about, they have their own streams. For example RFC 4844 is from the IAB stream.
Finally there are Individual Submissions. Sometimes these are documents nobody in any Working Group or Area cares about, occasionally they are documents a Working Group abandoned because it was unable to reach consensus and those who favoured the document finished it up as an Individual Submission. In some cases they're documenting a thing the authors would like to be public, just to get it down on paper.
The "Legacy" indication just means RFC 768 is too old to be classified by stream, the whole idea didn't exist back then.
Serious UX work needed.
WRT UX - yes, it certainly could be improved. Issues and PRs gladly accepted :)
Also I like the "obsolete" tick box.
As the other commenter said, this trashes the back button/history by treating every keypress as a new URL. Make sure you use replace.
I've been thinking about doing authors. The constraint is performance; the site loads the whole index, so adding author info would bloat the initial page load out (right now the index is about 2.2M, and GitHub Pages gzips it down to ~380k). The solution is probably to put author search, etc. on a separate page.
Maybe just reversing the result order would give more useful results?
Great design, I only had to click Back about 3000 times.
> RFC1149: Standard for the transmission of IP datagrams on avian carriers
While a search for "avian" yields:
> 3 RFCs
> RFC6214: Adaptation of RFC 1149 for IPv6
> RFC2549: IP over Avian Carriers with Quality of Service
> RFC1149: Standard for the transmission of IP datagrams on avian carriers