I don't really know how FM200 systems work in data centres, but I'm guessing that if the fire didn't start from within the actual server room, FM200 might not save you? e.g. if a fire started elsewhere and went out of control, it would be able to burn through the walls/ceiling/floor of the server room, in which case no amount of FM200 gas can save you, right?
Another possibility, of course, is that the FM200 system simply failed to trigger even though the fire started from within the server room.
There is no published investigation details about this incident yet, I believe. Can somebody chime in about past incidents where FM200 failed to save the day?