The imminent stable-version apocalypse
lwn.net
lwn.net
Apparently with the exception of the masking to 8 bits, it seems like that's what's being tried in the end[1][2][3]:
> I did a release of the 4.4.256 and 4.9.256 releases today that contain nothing but a new version number.
> With this release, KERNEL_VERSION(4, 4, 256) is the same as KERNEL_VERSION(4, 5, 0).
> Right now I’m asking that everyone who uses these older kernel releases to upgrade to this release, and do a full rebuild of their systems in order to see what might, or might not, break. If problems happen, please let us know on the stable@vger.kernel.org mailing list as soon as possible as I can only hold off on doing new stable releases for these branches for a single week only (i.e. February 12, 2021).
[1] 8 Bits Are Enough for a Version Number -- https://news.ycombinator.com/item?id=26037687
[2] https://lore.kernel.org/lkml/1612534196241236@kroah.com/
[3] https://lore.kernel.org/lkml/1612535085125226@kroah.com/
Why wait? What is a slower cadence going to accomplish?
(Bracing myself for the introduction of Smart Nano Carbon, with individually addressable nanotubes)
IPv6 wants to reserve the lower 64 bits for RNG addresses (sure, fine), and the upper 32 bits for classification and global routing (also fine?); leaving 32 bits for inner-ISP subnet needs. In practice the ISPs seem intent on at _best_, for an actual business class connection (which I've seen) providing a /56 to that, but forcing stupid router firmware to eat /4 of that, leaving in practice a /60 on the business link.
"Stateless address autoconfiguration (SLAAC) requires a /64 address block, as defined in RFC 4291. Local Internet registries are assigned at least /32 blocks, which they divide among subordinate networks.[42] The initial recommendation stated assignment of a /48 subnet to end-consumer sites (RFC 3177). This was replaced by RFC 6177, which "recommends giving home sites significantly more than a single /64, but does not recommend that every home site be given a /48 either". /56s are specifically considered. It remains to be seen whether ISPs will honor this recommendation. For example, during initial trials, Comcast customers were given a single /64 network.[43]"
Really not looking forward to having to move or Charter finally implementing caps. With a lot of luck I'll be somewhere with municipal fiber, but I'm not hopeful.
[1] If you don't send an IPv6 prefix hint, you get a /64. I can get a /56 reliably by requesting it. Behavior with /48s is a bit buggy. Last time I tested it I could get a /48 some of the time, but sometimes the request would fail and I'd end up with a /64, so I went with the stable option instead.
Here's something I find really amusing. In the late 90s, when IPv6 was being introduced, the joke was that 128 bits would suffice until we all had massively parallel wrist watches. Which would never happen, certainly not in our lifetimes.
The iPhone was released in 2007.
We wouldn't use them up in the same way we used up IPv4, there really can be 4 billion devices to address. But I could see some important spaces becoming very crowded when you try to cram multiple levels of routing information into that small a space, resulting in exploding complexity of routing tables as you try to garbage collect from sparse areas.
Also loved this quote:
Leon Trotsky once said that "old age is the most unexpected of all things that can happen to a man".
Well, at least it had a fun Leon Trotsky quote...