What happens when s3cmd fails and after two months you discover the "Vault sync succeded" emails you have been getting were all illusory?
If the author is reading: please take the time to update your example, including proper error checking (at least "set -eu"), otherwise the people on the internet that are going to copy your script are in for a hard time.
Skeleton of the "incriminated" script:
#!/bin/bash
[...]
s3cmd sync ...
[...]
notify-send [...] "Vault sync succeded [...]"