"A switch (or an L2 switch :-) ) is an L2-only thing."
I don't know what L2 means. I suspect a definition of the various levels would expand the audience for this post. "A switch (or an L2 switch :-) ) is an L2-only thing."
I don't know what L2 means. I suspect a definition of the various levels would expand the audience for this post.https://en.wikipedia.org/wiki/Internet_protocol_suite#Compar...
> The IETF protocol development effort is not concerned with strict layering. Some of its protocols may not fit cleanly into the OSI model, although RFCs sometimes refer to it and often use the old OSI layer numbers. The IETF has repeatedly stated that Internet protocol and architecture development is not intended to be OSI-compliant. RFC 3439, referring to the Internet architecture, contains a section entitled: "Layering Considered Harmful".
Anyway: People sometimes like to pretend that OSI is a model and TCP/IP implements the model, forgetting that OSI is/was a protocol stack and TCP/IP has no interest in being "compliant" with any other protocol stack to the extent it mimics its layering architecture.
Plus, the OSI model is rather complicated; there's a "TCP/IP Model" with four layers which is a lot simpler:
https://www.geeksforgeeks.org/tcp-ip-model/
> Process/Application Layer
> Host-to-Host/Transport Layer
> Internet Layer
> Network Access/Link Layer
(This seems to be the RFC 1122 model, BTW.)
RFC 1122 and RFC 871 each have models, too.
RFC 871 has:
> Application/Process
> Host-to-host
> Network interface
This is the inside view of how exactly a router operates. You only need to know this if you are poking inside a router implementation. If that is the case, my condolences.
If you're poking inside a router implementation, it seems fair to expect that you have a basic understanding of OSI networking layers.
Ethernet. L2 means Ethernet (or WiFi). Ethernet is the envelope we put Internet traffic in (L3) and the layers above that are about nailing down how exactly a conversation is managed. Sometimes people get upset about what constitutes Layers 5-7, especially since that Tim Berners-Lee joker ruined all the pretty pictures with HTTP. So mostly we only talk about 2,3,4 and 7, in the same way you don’t bring up religion or politics at a family reunion.
This is the first time I am reading this, I interpret this to mean HTTP is badly designed and Tim Berners-Lee caused it. Need more...
I'm aware there are levels of information in an IP packet, but I don't know them offhand. If I have to google something on the first sentence in a high level overview, then I'm likely not going to read the piece and the author has lost me as a reader. Maybe I'm not the target audience, though I was interested. I'm providing that as feedback for the origial author since the piece mentions that's it's still a work in progress.
Discoverability lives in the space between overexplaining and underexplaining.
¹ Three Letter Acronym/Abbreviation
It's like TTL. It means one thing in a networking context but something totally different in a digital logic context.
But granted, somebody with no networking background wouldn't necessarily know that.
Then the author wouldn't have to, and we wouldn't need to use a search engine!
[0]: https://en.wikipedia.org/wiki/OSI_model#Layer_2:_Data_Link_L...
Correction: the network stack has layers, where IP is one of them, near the top.
Which is why most software targets IP. It’s a good abstraction and it’s portable.
Arguably even this layering system is too rigid for reality but it's a decent model. See RFC 3439 section 3.
1. physical layer, 2. data link, 3.vnetwork, 4. transport, 5. session, 6. presentation, 7. application layer.
So, many switches are layer 2, but layer 3 switches are often referred to as switching routers. This can cause two different switches to act differently from each other in certain network environments. It isn't that one switch "doesn't work" but that it isn't a router.
A router is nominally a L3 device, though most actually are L1-7. To work, you need L1 & L2, but in today's world, there are applications and interfaces that move the router across L1-7, though not to the same depth as purpose built application devices for example. Topping this off, some routers will switch and some will not. It's the same wide-world of words that we see across the whole computer industry.
The OSI model differs from the TCP model of networking, even though both use numbered layers.
Some devices can do L2 and L3 at the same time. That’s why another term came up: L2 only switch.
And so on, you can read it more on [1].