Hacking Ethernet out of Fibre Channel cards
blog.benjojo.co.uk
blog.benjojo.co.uk
Brilliant.
1: https://www.reddit.com/r/AskUK/comments/3tt95u/how_many_litr...
Obviously the entire thing fails if any node is powered off or has any kind of problem, but it's quite funny to do ;)
Indeed it was funny enough to have that be a very common network topology back in the day. I've never had to investigate a token ring network failure but I can pretty much guarantee it was a frustrating exercise.
https://en.wikipedia.org/wiki/Media_access_unit
(un)fortunately I didn't experience this period of network history first hand. :)
The nice thing about FDDI was it could tolerate one node failure, because it has two rings. (Each node has two fiberoptic cables to both its neighbors.) If a node fails, its neighbors just send traffic the other direction.
A bit of googling turned out that it was possible and supported by the manufacturer - if you ran Linux 2.6 and were prepared to compile the kernel drivers yourself. We quickly ditched the project when we found out that the old driver made newer kernels panic and setting up link aggregation on normal gigabit ethernet cards wasn't that much of a hassle anyway.
I'm suprised they ever compiled on a newer kernel.
It wasn't that much of a lift for most organizations to just have an IP network for IP type traffic, and leave their high performance FC fabric alone to do its thing.
The few situations when it was done was when someone had some rando traditional IP systems that you'd connect just because, but these were corner cases / kinda forgotten bit of equipment that you just were waiting to replace / time out kinda situations.
I worked with some FCIP and given the right case and planning, that could work, within the right context.
It worked fairly well once it was up and running, and you set the QoS correctly so that FC traffic won out over Ethernet because Fiber Channel does NOT tolerate drops very well.
FC is solid generally once you've got it running, the protocol kinda ensures that.
I certainly hope someone has turned that off by now.
I do have one server with a built-in Intel card, that is more annoying, so I'd steer away from those in the future. The Intel card did not take all transceivers. They only wanted Cisco branded transceivers (from the ones I had available. I'm gonna guess, Intel ones would be fine too).
Top-tier stuff.