Let's Encrypt certificate issuance was down
letsencrypt.status.io
letsencrypt.status.io
this smells like a tickbox on an incident response webform - the responder is just clicking "we have identified", "production database" (or network issue or ...) and the response handler does the rest
would love to hear more
https://community.letsencrypt.org/t/2019-11-17-autoincrement...
Once a post-mortem is done there will be more information.
Status.io is where we post status information, not long-form explanations. The responses aren't canned the way I think you mean it, they're just meant to tell you status information quickly and clearly - is it up, is it down, what services are affected, how long until they're back up...
Once we have a fairly complete picture of what happened to communicate, we communicate that on our community site.
https://medium.com/enigma-shards/lets-encrypt-uptime-and-ope...
However, should you fail to renew a cert, your script should just keep retrying until the API is back and you should allow enough time for it to fail. I believe most clients renew certs ~10 days in advance.
Obviously if you're relying on getting a new cert to bring up something like a preview environment or to hand out your own subdomains, this will result in a downtime/delay in provisioning, but most people would be fine with a single wildcard and never really experience a problem, as long as their script runs and they keep it reasonably up-to-date.
The recommendation and the time certbot uses is 30 days.
It will predictibly fail until D-30,and then there will be 30 attempts to renew (in case something went wrong firth the 1st,2nd etc attempt)
Not only does doing so save someone from having to write them on the fly when they're worrying about other things, they can encourage you to communicate specific factors ("OK, we think we've found the problem, let's publish the message to that effect now"), remind you to think of certain things ("we think we'll be up within the hour" "we don't know yet how long it will take to fix" etc) and for that matter, if you have further failures, help someone look back to see how the process went.
> November 17, 2019 19:33 UTC > [Resolved] We have resolved the issue that was affecting production certificate issuance. Service is restored.
EDIT: Actually I'm wrong. It also checks if the certificate was revoked via OCSP. However I can't imagine that it consumes much resources.
I tried many things, and can verify the cron task renews when I test it, but months later it always fails.
I also set up traefik with auto renewal so it's a setup and forget thing now.
It does your auto renews in the background.
2. With the certbot client, instead of using a deep integration with your http server, you can use `certbot certonly --webroot --webroot-path /var/www/html/.well-known/ -d example.com` (or similar) and provided you told your web server to serve file from the /var/www/html/.well-known/ filesystem directory under the /.well-known/ url path prefix on your domain, cert issuance and renewal will work. This should be easy to do with any web server. certbot will not know which web server you happen to use and will not care. You can replace the web server and renewal will keep working.
Lots of instructions for many common situations here: https://certbot.eff.org/all-instructions
Did you check that you were running it with the right command flags?
If certbot has a bug that breaks things in a situation it's intended for do file a bug or even better a patch to fix the bug.