A sane CDN doesn't cache error responses. There is no legitimate reason to cache a non 2xx/3xx response, unless you / your CDN is really pinching pennies.
Caching a 5xx kinda makes sense I guess, but a 4xx client error? That's nuts.
Caching a 5xx kinda makes sense I guess, but a 4xx client error? That's nuts.
For example, every browser requests /favicon.ico by convention. If you don't have one, you wouldn't want every single request reaching your backend.
It's not an ideal design but I wouldn't call it 'horrible'.
Technically it stands for "common gateway interface" but that doesn't come up very much.