If you have your tokens take more than an hour to expire, you're doing it wrong.
The point is that you have two tokens, one a refresh token and one a stateless token. You revoke the refresh token on the server, which means the next refresh attempt will fail.
Still, an hour is a LONG TIME when a session could just kill all requests immediately for a user.