I had a similar experience with moving my Ubuntu 16.04 image over to Debian. My Debian reimaging, where it warns me all data will be destroyed for an untouched Debian installation, had it's repos configured to use Ubuntu's, on my Debian reimage, which of course failed. At first they blamed me, suggesting I did something I can not remember, and then I changed the repos as they suggested and demanded an answer when it did not fix it. They admitted their repos have an issue that I can not solve and I have to destroy the machine completely to be able update or install to my Debian machine and lose my IP address that my DNS is set to.
They said this issue only happens when you reimage from Ubuntu 16.04 to Debian. Which I believed at the time since I was tired from this. I do not know if I believe them after the above post.