Special-Use Domain 'home.arpa.'
tools.ietf.org
tools.ietf.org
https://en.wikipedia.org/wiki/.arpa
> While the name was originally the acronym for the Advanced Research Projects Agency (ARPA), the funding organization in the United States that developed one of the precursors of the Internet (ARPANET), it now stands for Address and Routing Parameter Area.
http://articles.chicagotribune.com/1994-06-26/news/940626022...
Because 'home.arpa.' is not globally scoped and cannot be secured using DNSSEC based on the root domain's trust anchor, there is no way to tell, using a standard DNS query, in which homenet scope an answer belongs. Consequently, users may experience surprising results with such names when roaming to different homenets.
To prevent this from happening, it could be useful for the resolver on the host to securely differentiate between different homenets and between identical names on different homenets. However, a mechanism for doing this has not yet been standardized and doing so is out of scope for this document. It is expected that this will be explored in future work.
Given that the IETF specifically needed to "home" zone to be unsigned, that would result in lengthy process to change the policy for the root zone. The root zone is managed by ICANN who implement the IANA function. And then operationally managed by Verisign.
In the end using something under .arpa, solved a lot of issues.
It is quite possible that the IETF could have allocated .home because it is currently unused. But that would still require solving the technical issues.
At the same time, as long as there is wide spread use of .home, ICANN cannot really allocate that as a new gTLD.
So it should be sort of safe to continue to use that. But "homenet" compliant routers should come with home.arpa preconfigured.
Between the lines, I read that ICANN doesn't give a f- about home users. Home users are not on the ICANN board (they've never heard of ICANN), don't give presentations at conferences or write papers, don't talk shop over lunch with ICANN members ... home users are invisible and have no voice. 'So here's this kludge that requires zero effort from us, is probably a little confusing for you[0] - we hope you like it because we're not doing anything more.'
The IETF can ask for domain names for technical reasons, i.e. as part of internet standards.
ICANN can allocate domains as gTLDs but doesn't have mandate/policy to reserve names without using them. Effectively .home is reserved because there is too much use to safely allocate it.
Finally, IETF can recognise .home as a special domain that is used locally. But that didn't work out because an insecure delegation is needed for DNSSEC.
Purely formally, ICANN has 'at large' structures that represent the interests of users.
(I still miss Australia being .oz, instead of .au.)
$ getent hosts hermes.dra.hmg.gb
146.80.9.16 hermes.dra.hmg.gbhttps://www.google.com/search?client=ubuntu&channel=fs&q=rev...
> There is an existing process for allocating names under '.arpa.' [RFC3172]. No such process is available for requesting a similar delegation in the root at the request of the IETF, which does not administer that zone.
> In response to the report, ICANN labeled the .home and .corp strings as "high risk" and proposed that neither of the strings be delegated until it could be proven that risk is low. These two strings are currently severely delayed and some community members guess they may never be delegated.
For a while Microsoft was telling companies to use .corp internally, these days their advice warns against this, but good luck getting a huge company to change anything in less than a lifetime.
When I say these names are poisonous I mean that in two senses
1. A tremendous number of people can't resolve your name in this suffix. Many of them won't know why, and can't really be expected to "fix" the problem.
2. Name servers for these suffixes receive a tremendous amount of "bogus" traffic that leaked from people who used these names but didn't properly seal them off from the Internet. Serving this traffic costs money.
Now, we recently saw for 1.1.1.1 that something so badly abused as to be poisonous can be reclaimed anyway if the people using it go in with their eyes open. I'd liken this to the practice of marking low value areas known to have some unexploded munitions buried as unsafe for humans and letting people run sheep, goats or cattle on that land on the understanding that (1) under no circumstances are people to enter and (2) sometimes an animal will explode, that's too bad, but hey the land was rent-free and would otherwise be useless. But just selling off land with unexploded munitions for building a new housing estate is clearly negligent.
I kinda missed that part of the story. ref?
Internet Noise (Announcing 1.1.1.0/24) https://ripe76.ripe.net/archives/video/31/
https://tools.ietf.org/id/draft-chapin-rfc2606bis-00.html
>Recommendation (2) of SAC 045 calls for the community to develop principles for "prohibiting the delegation of additional strings to those already identified in RFC2606 [RFC2606]." As the first step in that process, based on the data reported by SAC 045, this document adds to the list of names that may not be used for top-level domains the following labels:
>.local, .localdomain, .domain, .lan, .home, .host, .corp
Now it seems like those TLD may be sold in the future? 1&1 is even "pre-registering" those TLDs.
Because if this was _your_ idea then if I were the client I'd feel like I hired somebody who was totally incompetent when I find out this arbitrary name they picked for me is a dumpster fire.
You're quoting an _expired_ _draft_ document as if that's some sort of standard.
* http://jdebp.eu./FGA/dns-use-domain-names-that-you-own.html
"A reserved top level domain name, '.pri', would allow a private domain name to be chosen safely with no risk of conflict with current or future registered domain names. A private DNS server is configured as authoritative for the '.pri' domain, and delegates the private subdomains as appropriate."
It sadly was never picked up[1].
Over the years, Microsoft has recommended and in some instances even forced[2] the use of .local, which they now advise against[3].
[0] http://tools.ietf.org/html/draft-coffeystrain-privatednstld-...
[1] https://datatracker.ietf.org/doc/draft-coffeystrain-privated...
[2] https://www.microsoftpressstore.com/articles/article.aspx?p=...
[3] http://technet.microsoft.com/en-us/library/cc738121%28WS.10%...
* http://jdebp.eu./FGA/dns-use-domain-names-that-you-own.html
It's so cheap now and such a benefit to have a publicly-accessible and publicly-reserved address. There's no need to make your DNS records publicly-accessible although it's often convenient and rarely a risk.
Is this going to fuck that up?
But now you can just use `mycoolawesome.home.arpa` without registering it.
Now you can get Lets Encrypt certs for routers and all sorts! Use a Dynamic DNS service if external IPs are not static.
My family may be a little unusual in that even my Dad's TV has a hostname, and so has my brother's cooker! I put in pfSense, multiple VLANs, Unifi APs and all the other good stuff. A fully meshed IPSEC VPN link up with split horizon DNS. pfSense has an ACME client and a full toybox of networking goodness. Each site config is mostly replicated to the others for backup. The office monitoring system (Icinga) has a few extra systems on it.
That lot took a couple of man days to set up. It looks after itself mostly now and just works. I've saved myself many, many hours of hassle by putting in the work ahead of time and specifying decent gear. Its probably not for everyone.
* Use .home.arpa
* Use .test from RFC2606.
* Use mDNS, which basically every printer supports, and use .local.
* Get yourself a personal domain. I highly recommend it. All my internal stuff is under home.mydomain.tld.
I'm confused about ".local" though. It's reserved for Multicast DNS? [2]
[1]: https://www.iana.org/assignments/special-use-domain-names/sp...
$ dig -p 5353 raspberrypi.local @224.0.0.251
; <<>> DiG 9.8.3-P1 <<>> -p 5353 raspberrypi.local @224.0.0.251
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 21640
;; flags: qr aa; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
;; QUESTION SECTION:
;raspberrypi.local. IN A
;; ANSWER SECTION:
raspberrypi.local. 10 IN A 192.168.1.175
A DNS query packet is to the multicast address 224.0.0.251 and UDP port 5353. All devices on your network that are listening on that address will see the query (e.g. Linux systems with avahi-daemon or Macs running mDNSResponder). The device whose name is raspberryi will respond. RFC6762 should have all the details.(It's useful as a development tool as you can Virtual Host project1.localhost and project2.localhost to different in development sites if your OS and server support it, which tend to be in similar ways to how they generally support Virtual Hosts.)
6.3. Domain Name Reservation Considerations for "localhost."
The domain "localhost." and any names falling within ".localhost."
are special in the following ways:
1. Users are free to use localhost names as they would any other
domain names. Users may assume that IPv4 and IPv6 address
queries for localhost names will always resolve to the respective
IP loopback address.
[...] 3. Name resolution APIs and libraries SHOULD recognize localhost
names as special and SHOULD always return the IP loopback address
for address queries and negative responses for all other query
types. Name resolution APIs SHOULD NOT send queries for
localhost names to their configured caching DNS server(s).
And goes on to specify how resolvers, authoratitive DNS servers, registrars, etc. should behave.This is implemented on my machine at least by systemd_resolved, see https://github.com/systemd/systemd/blob/master/src/resolve/r... which returns ::1/127.0.0.1 for any record for which which is_localhost is true (defined in https://github.com/systemd/systemd/blob/master/src/basic/hos...).
I hope ...