Specifically there is some error in generating a PID file in the system-d service call.
I solved the problem by removing/commenting out the run PID line in /usr/lib/systemd/system/slapd.service
Specifically there is some error in generating a PID file in the system-d service call.
I solved the problem by removing/commenting out the run PID line in /usr/lib/systemd/system/slapd.service
ICYMI, the openldap-servers package is "deprecated and will not be included in a future major release of Red Hat Enterprise Linux".
For RHEL, that means it will remain in the 7.x versions but will not be included in 8.x when it is released (which should be Real Soon Now(tm)).
For CentOS, that also (likely) means that OpenLDAP will not be included in future (major) versions.
[0]: https://access.redhat.com/documentation/en-us/red_hat_enterp...
openldap upstream suggest using these on CentOS / RHEL over the redhat packages, if operating the server components.