IP over Avian Carriers
en.wikipedia.org
en.wikipedia.org
And just to say, people are often surprised at how readable the RFCs are. But they are intended to be understood, each one is explicitly intended to be the document you use to actually implement something.
There is value in learning how to read an RFC, and RFC1149 is as good a place to start as any. Others that are worth reading include:
* RFC 768 : User Datagram Protocol (UDP)
* RFC 793 : Transmission Control Protocol (TCP)