Let's say I have an EBS volume of 500GB with 300GB of data. What happens if I mistakenly resize the EBS volume to 200GB? Do I get an error message or does part of my data get wiped out?
Bad news: that's because you can't make your EBS smaller.
> You can now increase volume size, adjust performance, or change the volume type while the volume is in use.
Note the absence of 'increase OR decrease volume size'.I'm quite happy to lose data, or manage my data's physical location on disk, and do online decreases… but I can't!
(Yes I know that's probably not what you meant, but it does highlight the question of what exactly is non-valuable data?)
> what exactly is non-valuable data?
Caches, mirrors, backing volumes for redundant data stores or processing infrastructure that indicates to try again on another node on failure.