Instance and host reliability aren't the issue here. The issue is that a disgustingly high number of enterprises rely on vSphere High Availability and Fault-Tolerance features to restart VMs or keep them alive when an OS hangs or the host fails, instead of architecting for high availability at the app layer.
To be entirely fair though, vSphere HA and FT are incredibly friendly to the bottom line relative to rebuilding apps that simply weren't designed for HA.