The mining algo has nothing to do with it. As soon as the hard-forked clients get to the block on the non-forked chain where the hard-fork causes it to be rejected, it will reject the whole chain. It doesn't matter how long the chain is or how much work was applied, if the rules don't allow for the block it's rejected (and therefore the whole chain).