The main reason I switched Docker is there's an nginx image (on alpine) that supports ALPN. No compiling from source required, which simplified things (in my mind, at least).
For me, the first HTTP/2 POST request to a server running the affected version of nginx would never leave the browser and Safari left a less than descriptive "Failed to load resource: Could not connect to the server." console message.
I'm having luck with 1.9.12 + OpenSSL 1.0.2h