Some know-it-all busybodies like to proclaim that anycast can't work for TCP because the route can change during the session, but the reality is that:
- route changes are infrequent
- individual sessions are typically much shorter than route change intervals
- we never experienced proposed problems with sustained route flapping
- route changes are readily detected and handled as (rare) dead connections. The nicest bit is that transferred live connections can get rejected and closed immediately by the new server allowing for rapid recovery (unlike DNS changes which leaves things hanging for a long time).
We had extremely fast datacenter failover using anycast (100% of traffic moved as soon as 5 seconds). Contrasted to the minutes-to-hours nightmare delays that characterize DNS failover. (The DNS time-to-live is an advisory at best, and outright ignored by many clients)
It's too bad more hosting providers don't allow route announcements.