US DoD starts using 11.0.0.0/8
mailman.nanog.org
mailman.nanog.org
What they did do was start advertising it into the global BGP routing table (technically, AS23352 did, as the post mentions) -- apparently ~5d6h ago, according to my routers.
In addition, AS23352 is sending the ("informational") community "23352:41216" along with this prefix, which means that it was learned by a "customer" peering session at their Chicago, Illinois, POP:
Community: 3356:3 3356:22 3356:100 3356:123 3356:575 3356:2042 23352:41216
The other communities attached to this prefix indicate that:a) ServerCentral is a Level 3 customer, and
b) Level 3 is receiving the announcement from SC in Chicago.
FWIW, I'm receiving the routes via Level 3 peering connections in both Chicago and Cincinnati, Ohio.
[0]: http://evilrouters.net/2010/10/20/arin-regains-458-from-inte...
See Comcast's presentation about their motivations: http://meetings.ripe.net/ripe-54/presentations/IPv6_manageme...
Let's say my company uses 10.0.0.0/16. Now let's say I set up a VPN. Half my users will be on local networks that are also 10.0.x.x. Fail.
Even worse, let's say my company has two locations and both use 10.0.0.x and now we want to link them on a common network using a VPN or virtual Ethernet bridge. Have fun renumbering one of these two sites, or setting up abominations like internal two-way SNAT/DNAT.
The reason IPv6's address space is so huge is to allow relatively stateless assignment of addresses with extremely low probability of conflicts. An IPv6 address is basically a UUID. That's going to make lots of things easier and eliminate the need for a huge number of nasty hacks.
This is exactly why I use 172.16.104.0/21 as my home network range. Almost no one else does so it makes things really easy when I VPN home from a hotel somewhere.
This is the reason why I can't believe we're not all on IPv6 yet. You would think that the online advertising industry would have done everything in their power to push IPv6, at any cost. 90%+ of people on IPv6 will literally have a unique identifier FOR LIFE on every device they own. Marketers can now pinpoint down not just to an IP address that identifies a single NAT interface, but each individual device.
I hope that operating systems and/or routers will provide the option to rotate each IPv6 address on a routine basis. It would also be nice if ISPs would rotate the block that is handed out to each customer, but this is unlikely to happen. Every phone, every tablet, every PC, every thermostat, every door lock, every fridge... uniquely identifiable from the day it is hooked up to a network. :(
[0]: http://gcn.com/articles/2012/06/07/fbi-wants-ipv6-hard-to-tr...
It seems like Linux may be a mixed bag (by distro) w/r/t it being enabled as default. I could definitely see cheap embedded devices based on a current Linux distro not bothering to change defaults to enable it.
This is an issue when using SLAAC, yes, but a workaround ("Privacy Extensions") were developed years ago; cf. RFC4941 [0].
You can also assign static addresses or use DHCPv6 -- on your own networks, at least; you obviously can't control how your ISP decides to issue addresses.
I use 192.0.2/24 ("TEST-NET") at home (cf. RFC 5737), split up into various subnets. At $work (ISP), we use 100.64/10 (cf. RFC 6598) quite a bit internally (for its intended purpose, *mostly). In other networks, such as companies with many locations that will be connected via VPNs or companies that will have several VPNs to other organizations (where there's less control of the addresses used), I've used 198.18/15 (cf. RFC 2544) to avoid any conflicts.
Obviously, this is not what those address ranges are intended to be used for but it's certainly better than both a) using non-reserved address ranges (i.e. public ones that don't belong to you) and b) implementing funky NAT policies because of overlapping addresses.
I asked which private network they switched to and he said "We switched to 11-dot, because no one else uses it and it'll be unique for the future growth of our private network."
Needless to say, he was not pleased to learn it was not private, or unique and was assigned to the DoD.
A shorthand version would be better.
Ideally if the router ip address is 1, Subnet would be 1.0/24, Client 1.2
Client IP: 1.1
Router: 1
Subnet: 1.0/24
Gateway: 1
I'm too lazy for ipv6. Nothing to celebrate about ipv6 except for a bigger pool and some other minor +.
Either way if those users want routable IPs going forward and not be stuck behind CGNAT then they'll have to use their brains and learn something new.
The truly lazy people like yourself and remain in some sort of segmented Internet I suppose.
> The truly lazy people like yourself and remain in some sort of segmented Internet I suppose.
That last sentence doesn't add anything to the conversation. Your comment wouldn't lose anything by removing that.
Also, this one:
> they'll have to use their brains and learn something new
could have been simply written as follows, again without losing anything:
> they'll have to learn something new
> I'm too lazy for ipv6. Nothing to celebrate about ipv6 except for a bigger pool and some other minor +.
Symmetrical construction is nice. :)
Additionally, it's pretty appropriate to say:
> Either way if [advanced users who are setting up static, globally routable IPs for machines] want routable IPs going forward and not be stuck behind CGNAT then they'll have to use their brains and learn something new.
Any sysadmin who is configuring a server that requires a globally routeable IP is expected to use his brain. Moreover, he will be expected to have to use that brain to learn new things from time to time, lest his systems become crusty and unmaintained.
There are many things that can go wrong when you configure a machine as an Internet peer. Some amount of savvy and smarts is required.
Good point. But I found the OP's statement inappropriate, either.
> Any sysadmin who is configuring a server that requires a globally routeable IP is expected to use his brain
Everyone is expected to use their brain. Implying that somebody doesn't use their brain is dehumanizing.
That kind of isults should have no place on HN.
OP (workworksleep) was calling himself lazy. You consider it inappropriate to call oneself lazy?
> Everyone is expected to use their brain.
If you work in a technical field, and have not had the inhuman good fortune of never working with C or D players, you will know that some sorts of people will -not infrequently- fail to meet expectations by failing to engage their brain. This isn't an insult, it's a statement of fact.
A Comp Sci student who requests that others write his 1xx or 2xx level homework for him would be quite rightly accused of not using his brain.
Hell, on my worst days, I've failed to use my brain and spent 8+ hours writing code that was -at best- hilariously roundabout and overly complex or -at worst- didn't even solve the problem I had intended to solve. When reviewing days like that, I openly admit to not using my brain and accept the shame and wasted effort that came from my failure.
What would you call a network administrator who knew IPX/SPX inside and out but refused to learn IP networking, declaring -like workworksleep did in his OP- that he was "too lazy" to do so and that there wasn't enough benefit to overcome his laziness?
Indeed, "use your brain" is not an insult if you say that to people you know pretty well, especially if they just did something extremely stupid that was easily avoidable.
However, I still find it inappropriate to say that to strangers on the internet which you don't know. Of course you can try to extract a lot of character information out of a single sentence that somebody said, but the error rate is quite high.
Now, I do agree that it's a massive chunk and it could be better used given up to the rest of the internet, but honestly we should be pushing harder on ipv6 instead.
The whole "They are the greatest force against peace and for suffering the world has ever known" part is a matter of opinion and I disagree with that statement.